Please help asap with Comodo firewall+Nintendo Wii [RESOLVED]

Hey guys. I have a wired linksys 4 port router. BEFSR41 V4.0. Im also on cable internet. I purchased the nintendo usb wifi adapter. I can get everything to connect with my firewall shut off. However when its on. My Wii wont connect. So its a firewall issues. How do I set up the firewall for the Wii? The usb adapter uses ICS. So for me this is a bit of a tricky situation. This is how my setup looks in ipconfig/all

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Owner>ipconfig/all

Windows IP Configuration

    Host Name . . . . . . . . . . . . : Brent
    Primary Dns Suffix  . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti

on
Physical Address. . . . . . . . . : 00-11-11-95-5D-89
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 68.116.46.70
68.116.46.115
68.185.34.67
Lease Obtained. . . . . . . . . . : Friday, July 13, 2007 7:16:53 PM
Lease Expires . . . . . . . . . . : Friday, August 10, 2007 1:56:53 PM

Ethernet adapter Local Area Connection 20:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Nintendo Wi-Fi USB Connector
    Physical Address. . . . . . . . . : 00-0D-0B-C4-A9-CD
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 172.16.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

C:\Documents and Settings\Owner>

Since the wifi adapter uses ICS. I cannot change anything as far as that goes. Its a long story but its an nintendo thing not something else. Please step by step if ya can. Im a newb at this networking stuff.

G’day,

There’s an easy to follow tutorial at

https://forums.comodo.com/faq_for_comodo_firewall/nintendo_wifi_connection_tutorial_wii_ds-t4429.0.html

One thing I noticed from your post is that your LAN IP address is 192.168.1.100, but your Nintendo adaptor is 172.16.0.1. If you want to be able to get your PC and Wii talking, they are going to have to be on the same network. I’d recommend chaging your Wii adaptor address to 192.168.1.101, so its on the same subnet as your LAN.

Hope this helps,
Ewen :slight_smile:

Thank you so much! My DS and Wii are all playing nice together. Everything works perfect now. Very good tutorial. I would have loved to be able to change the ip address on the wifi adapter to the 192.168.1.101 but it wont work. Like I said in the first post. Its an nintendo issue and just the way this adapter was designed. Thats my only complaint about it. One last thing im hoping you can help me with. How would I set this up using an Xbox 360 added into this mix? I had a 360 but it broke. Will be getting another one down the road again. I modded it so couldnt send it in. Anyways. At the time. I added a new zone and ran the trusted network wizard. Selected the new pc/360 setup I put in there. The ips used were 192.168.1.100 and 192.168.1.101. It worked great. But like I said. Now I have a DS and Wii using this wifi usb adapter so its a little tricky now. Really hope you can help me on this. Thanks again for all your help! (:KWL)

Can someone please help me on my above post?

Hey Korn,

You’ve answered your own question. :wink: If you had it working before, adding the Wii on a different subnet shouldn’t make one iota of difference. All you’ll need to do is set the IP of the XBox to 172.16.0.X (where X is different to your Wii and PC address), run the zone wizard so it includes the new address of the XBox and you should be right.

Cheers,
Ewen :slight_smile:

My 360, DS and Wii are all working in harmony now. Thanks again! :BNC

Great to hear. I’ll close this topic as we seem to have resolved successfully.

Cheers,
Ewen :slight_smile: