Persistent C from comodo on my screen [merged]

Using Comodo Firewall 8 and I seem to have an invisible prompt. Showed up earlier, nothing in logs, I rebooted, then it seems to have showed up again. See screenshot, there in the lower right corner of the screen, can just see the corner of the Comodo window. Can pick it up and move it, but that corner is the only thing that moves, no rest of the window showing up, and it won’t go away.
What gives and what do I do with it?
Mod edit: Added merged to the topic title, Captainsticks.

[attachment deleted by admin]

What happens when you close the interface from the Comodo icon in the systray and then open the interface again by clicking on the Comodo shortcut on the desktop or start menu?

This started up for me today also. Exiting Comodo and restarting just brings it back. same with rebooting. Version:

So I’m guessing there was an update? Or may it have been an update to something else? No Windows update that I know of, and don’t have it set to auto-install…

And to answer, exiting makes that tiny corner of a prompt go away and after restarting it it didn’t yet reappear in 30 min. After reboots it reappeared in about 15 min, both times.

Are you using a program to change how Windows looks like f.e. Windowblinds?

It’s odd it takes so long after booting to show up. It is also odd it’s not minimised. Can you check with Task Manager if cis.exe is running before the corner shows up.

Can you see what happens when you change the properties of shortcut of CIS to open maximized and then open it?

It just recently showed up, within the last hour and it’s really annoying. It first showed up as if it was from the Comodo message center and it refuses to go away. I can move it around, but it’s always on top and in my way. How do I get rid of this? Thanks.

[attachment deleted by admin]

I merged your topic with an already existing one. Is it a coincidence it starts to happen around the same time for two users? May be some strange Easter Egg? :wink:

Please check my previous post .

I’ve uninstalled and reinstalled with a fresh download. It seems to have gone away. At least it hasn’t shown up again in almost an hour.

This just happened to my 2 computers as well!!, both win8 and 7. What going on over at Comodo?
How can i trust this program to be safe if stuff like this happens?

Also, i know i set at least win8 to not update itself… so why on earth do i have the latest one? (

Please don´t joke about this. It “might” “look” harmless to you but we don´t know that. If something like this happens how do we know the rest of Comodo is working like it should?

[attachment deleted by admin]

Have you got the box ‘Show messages from Comodo Message Center’ ticked?

It looks very much like a message or rather part of one in the bottom right corner which is the usual place.

Have you tried to kill the process for that?

Possible corrupt message that has been sent.


I can’t seem to kill the cis process. Un-checking the message center does nothing.

[attachment deleted by admin]


I probably have not been observant enough previously but I have noticed a small item that appears in the bottom right hand corner of my desktop. It takes a few minutes before it appears. It is right in the corner so the complete item cannot be seen but it looks like a light coloured letter ‘C’ on a dark background. I am posting in this forum because it seems it might be part of a Comodo image - it looks identical to the the first part of the initial letter ‘C’ in ‘Comodo’ in the main Comodo desktop menu that I have positioned top right of my desktop but the second part of the letter is lost as it is off the screen edge.

I would like to be reassured that this item is normal and does not represent anything untoward. As I said, I may have not been very observant in the past so it may have been appearing from ages ago but as it is rather small, it is easily missed.

The item does not respond to mouse clicks left or right.

Thank you

Please read here;msg794428#msg794428

Hi all.
I use Comodo Antivirus 7 and in the last days I see a strange black rectangle on my screen. It surely belongs to Comodo.
See attachment.

It may be dragged everywhere on the screen. It’s inactive, a double click does nothing. No context menu appears. It’s always “on top” of any other window.

What is it???


[attachment deleted by admin]

Yes, that show messages box is checked, and I guess it may be such a message, since nothing shows up in logs otherwise. Still didn’t reappear after turning it off and then back on that time in my case (computer was left on, as it always is).

And in my case the first time it appeared was shortly after midnight, around 12:05 or so, or at least that’s when I noticed it, so joke or not it does seem like something triggered by the date.

I have listed binary updates at 12:28 and 1:41 AM. 12:28 was some 1-2 min after it showed up the 2nd time, ~15 min after the first reboot, at 1:41 I hadn’t even been at the computer in some 40 min. May it be that this 1:41 update cleared away that message? (Don’t exactly care to reboot again and check if I don’t have to.)

And yeah, cis.exe was running before it appeared.

My odd rectangle disappeared when I clicked on the icon that notified me that a Windows Update was available.

However, I do not have any advice for the person on another site who, upon being informed that a specific feature is not available in an Android app, then asked how he could enable that feature. That my method of removing the rectangle worked for me is not intended as a guarantee that it will work for you, as it may have been a specific feature available only to me.

Advanced settings-User interface-Show messages from COMODO Message Center - uncheck checkbox.

Thank you Dennis2. The link to the thread you provided at least gave some reassurance in that I am not alone regarding the issue and that this is a new problem. Sorry if I posted in the wrong place - I’ll keep an eye on the other thread but so far this mystery seems unresolved. Hopefully Comodo will come up with an explanation and a solution.


Haven’t seen the CMC for a long while (it’s not disabled in settings), but it’s just started popping up in the lower right corner of my laptop’s screen looking like this…

It can’t be interacted with apart from being able to drag it around the screen.

Edit: Sorry for not using the correct format for bug report - will do so if required.

Same issue here. I use Fences 2.0 BTW

[attachment deleted by admin]