Here is a VERY Basic Idea and I am SHOCKED that you do not have it…

-Comodo FireWall open
–Component Control Rules
–Allow/Block - (Who has What) I Block A Lot of Things and I can’t Get them all together like the Rest???

(EXAMPLE if you don’t understand simplicity…If you Click on COMPANY they all Gather as one)
…(get it)

AND WHY do you let so MUCH of M$ Talk to the Net? Are you and M$ Friends?
As I look into who you are…
Are you M$?

Hi and welcome,

By default there is an option that allows ‘safe’ applications to access the internet automatically which is why many of Microsoft (and other software) are let out without warning.

If you would prefer to turn this off then disable ‘do not show alerts for applications certified by Comodo’ under the ‘security’>>‘advanced’>>‘miscellaneous’ tab.


It helps to understand what the Component Monitor is/does…

Before an Application is allowed access, CPF verifies all components involved with that application/connection, checks them and if they’re okay, approves them as “Allowed.” The only thing actually connecting is the Application, in accordance with your Application Rules. The component list is simply CPF saying, “all these components have been checked out, and they’re okay;” it’s a security thing.

CPF has a layered approach to security; the groundwork is set in Network Rules - everything that is allowed to connect, connects only in accordance with the Network Rules. Next are the Application Rules - these are what are allowed (or not) to connect, in accordance with the defined Network Rules. Finally you have the Components which are utilized by the Applications. If anything changes with Apps or Components that does not conform with CPF’s security protocols, it will alert you (provided you have not turned off Alerts).

At this point, the Component Monitor is sorted alphabetically; the rules cannot presently be grouped by application usage, type, etc. You can change a component to “Block;” be sure to click OK after, and stop/restart CPF.

Hope that helps clear it up a bit for you…