Periodic "Oops You have discovered a Bug in CIS" crashes [File Attached]

The bug/issue

  1. What you did: I left the PC on overnight so that the weekly scan could run.
  2. What actually happened or you actually saw: In the morning I saw a dialog box that said “OOPS, you have discovered a bug in CIS” When I try to send the bug report, I get a second dialog telling me that it was unable to send the bug report. Winows XP cannot shutdown or restart using the normal “Turn off the computer” choices; I have to hold down the power button to make the PC shutdown.
  3. What you expected to happen or see: a normal scan report with issues or an empty desktop
  4. How you tried to fix it & what happened: I have run the comodo diagnostics, no trouble found.
  5. If its an application compatibility problem have you tried the application fixes here?: unknown
  6. Details & exact version of any application (execpt CIS) involved with download link:
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: This has happened several times in the past, and I have sent emails about it, but have not reported it via a bug report. No one has ever responded to those emails. I have scanned for the text “Oops you have discovered a bug” to see if anyone else has reported this bug and got “no results”, yet in looking at some posts in the forum titled “crashes” I found at least one other mention of the same issue, with the only response being a “file it in the right format.” All that I need to do is leave the PC on overnight, and sometimes it fails.
  8. Any other information (eg your guess regarding the cause, with reasons): It always happens when the PC is left on overnight, but not every time that the PC is left on overnight. In this last case, I had started it expecting to do some work, but did not, so the only thing that should have happened was that CIS initiated the weekly complete scan at 12:00 AM Sunday my time. From the logs, I am not sure that the scan completed, but I don’t think so because there is no results message.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Not available. Whenever this happens, the PC is only partially operable, some things work, some don’t.
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: Attached exports of the files for the month of April instead.
  3. A CIS config report or file. attached
  4. Crash or freeze dump file: I have attached all of the dump files in the CIS Dump folder.

Your set-up

  1. CIS version, AV database version & configuration used:5.3.181415.1237 AV 8461 ?
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: no
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: As far as I know I AM using a standard config, since I don’t know what a “config” is and you don’t explain it anywhere I can find. When I look at “configuration” under the Comodo system tray icon, the check mark is at firewall security and the entire line is greyed out.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= safe, Sandbox= disabled, Firewall = safe, AV = stateful
  6. OS version, service pack, number of bits, UAC setting, & account type:XP Media Center; SP3; 32 bit; this is XP, no UAC settings; administrator
  7. Other security and utility software installed: no other except windows firewall
  8. Virtual machine used (Please do NOT use Virtual box): none

[attachment deleted by admin]

Thank you for your Issue report in the correct format.

Moved to verified.

Thank you



Thanks for placing this in the “format verified” section. Once you filed it here, I scanned the rest of the reports in this section and found 5 other reports that appear to the same problem as mine. They are listed below, along with a sixth report that is similar but exactly the same issue. I had tried searching on the whole “oops! You have…” message string with no results, but found the five reports below by searchng simply on “Oops” in this forum subsection. When I tried using the “Oops” search at the CIS forum level, I got 9 pages of results, mostly unrelated but some were EXACTLY this same issue.

I am most disturbed that this problem appears to have been going on since at least January 1, 2011, and was first reported by user Valentin N who also appears as a responder on the post from PC-Pete. What is bothersome is that after reporting essentially the exact problem, Valentin N literally berates PC-Pete, telling him to file this issue somewhere other than in the “Bugs” section, and then suggests to another user that he should attempt to resolve the issue by reinstalling Windows! That is bizarre!

Here are users and times of the five matching reports, all in this forum subsection:
Valentin N on 01/01/2011 at 3:03:15 PM
WinBMY on 01/13/2011 at 3:53:50 AM
Myndzi on 01/26/2011 at 12:52:56 PM
XxBlackBirdxX on 02/08/2011 at12:11:49 AM
PC-Pete on 03/21/2011 at 12:50:05 AM

The similar report is from LennyV39 on 01/07/2011 at 12:39:15 AM

As I mentioned above, in scanning other areas of the CIS forum I found other people who had reported the same issue, but did not follow the instructions on bug reporting, so their reports were rejected, in addition to posts on the same problem simply placed in other areas. Therefore the problem is much more prevalent than just these seven reports. I have been receiving this error for some time now, and had foolishly been sending the crash reports to Comodo manually when clicking on the “Send report to Comodo” button failed and generated the “Please send this report” message with the location of the dump files. I have never received an acknowledgement form Comodo on any of those emails.

I don’t know how Comodo prioritizes its’ work or how the input from the forums is handled, but it is very disheartening to see the way that this issue has ignored and denied. And again, the responses from user Valentin N, who appears to be part of the Comodo staff, to PC-Pete are just beyond comprehension, given that Valentin N reported the issue first!

I run Comodo on three W7 laptos and one XP SP3 desktop, which is the only one experiencing this error. I don’t plan on abandoning CIS; it is a great product. But I am going to send this post to Melih since I think that he needs to know that his bug fix process has a bug in it!

Yes I know there are quite a few, but do not place them together as each crash may be different.

Thank you for attaching the dump :slight_smile:

As far as feedback it is very limited usually done by PM if any.


Thanks wrapper for your searching and summarising.

Some good news.
Having not followed the advice to reinstall Windows and having 3 different XP SP3 PCs all with the same “Oops” instability, I installed a different security app instead of CIS 5.3.
But I’ve now got 5.4 Pro “testing” on the PC which first indicated the problem and it’s been solid for a week!
Here’s hoping.

[attachment deleted by admin]

Thanks again wrapper - an exceptionally useful summary of the issue and its surrounding posts.

FYI - Valentin N is NOT Comodo staff. He is a forum member, just like you or I.

Ewen :slight_smile: