pc asking for Dell Resource CD after 3.0 update

Hi all:

I was notified a new Comodo version was available so I let it download and install. Now I keep getting messages it is still looking for the Dell Resource CD - specifically a file called RCD.MSI. I even inserted the Dell CD but it was unable to find it. Why is Comodo asking for the Dell CD?

Can I uninstall through control panel and download and install the previous version again?

Also, is the Defense compatible with my Avast Home 4.7. It says Comodo Defense is for malware and Avast is already protecting against virus. Are they the same so I should not have installed Defense?


I found this for you and have not tried it myself. Might be worth a try.


Hi, this is exactly the problem I have had with my DELL XPS, but I was trying to compile a VB6 program, and got the preverbial ‘rcd.msi’ message.
I don’t know if this is the the ‘right way to solve it’ … but it worked for me.

The system is actually needing two files, the rcd.msi file and the data1.cab file.
The only way I found of doing it was as follows:
A. Insert the DELL Resource CD in the Drive.
B. Click ‘Start’ and select ‘Search’
C. Select ‘All Files and Folders’ (3rd option down)
D. In the ‘All or part of the file name’ type ‘rcd.msi’
E. In the ‘Look In’ field, select the Dell Recource CD from the Dropdown.
F. Hit the ‘Search’ button.
G. The file is found almost immediately, but, this is the confusing bit, the file is not actually on the CD, but is ‘referenced’ to it from your PC …
H. Anyway, whilst you can still see the file name in the left of the found line of the search results box, Right click on it and select ‘COPY’.
I. Open up your Windows Explorer, and select a directory to copy it to. (I selected the DELL directory), and right click, and paste it.
J. Now do exactly the same thing for the ‘data1.cab’ file, and copy it to the same directory.
H. (You can remove the DELL resource CD now !)

Now re-run the application(s), and whenever you get that annoying message, just point the file name dialog box at the DELL directory.
It has worked fine on my system, hope this helps others.



Edit: Here is another option from Microsoft: