P. S. Translated by Google from Ukrainian

Put the firewall from Comodo … And so it got me no pop-reported issues - set a password on it and noted to have been no alerts when password protection is enabled … And then big trouble - in the password as the last character, I used the space bar … As I am now guessing, FIREWALL no such thing as … But password arrayed, So when confirmed! … Next is - Comodo refuses to accept (‘wrong password’, ‘wrong password’)… What to do? … Tell me please! …

Hello Sergij,

Go to Registry Editor (Start > Run > Regedit > Browse to HKEY_LOCAL_MACHINE > System > Software > Comodo > Firewall Pro > Configurations > Your Active Configuration > Settings)

HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\Your active configuration\Settings, change value 1 to 0 by pressing modify on entry PasswordEnabled.
Check whether value is 0 for PasswordEnabled entry under HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0,1,2 or 3\Settings.

You also have to change the PasswordHash the easy and safe way I think is to copy the hash from one of the non active configurations and paste in the active one.

By changing the 1 to 0 stops the password, but the hash is still there so you have to input the password once to clear which is no use to you.

:Credit Goes To Dennis

Does this help?


In 'Start > Run > Regedit > Browse to HKEY_LOCAL_MACHINE > System > Software > Comodo > Firewall Pro > Configurations > ’ I have ‘0’, ‘1’, ‘2’ - which should I chose?..

P. S. Sorry for my English…

No Worries; My primary language is english and I can barely speak it!

You’ll need to compare and see which value is changed in the PasswordEnabled key
(there should be a value of 1, you’ll need to change it to 0)

Then Change the Password hash (Copy the value of the ‘untouched’ configurations and paste it to the current configuration)

Hope this helps


I’ll try to explain a bit better;

0 = COMODO - Internet Security (Default)
1= COMODO - Proactive Security
2= COMODO - Firewall Security

So Find out which has the PasswordEnabled value of 1 Then Double click the object and del the 1 and put a 0
then, IF it’s the Configurations>0 then goto Configurations>2 and Double click the object named PasswordHash and Copy and paste it in the Configurations>0>PasswordHash

Hope This Helps

Thank You very much!.. It works… & was pretty simple… Thanks again!..

P. S. If You can understand in Russian - here

Do NOT use SPACEbars as the last symbol of Your passwords!.. :wink:

So, I have a problem. When I change the value to 0 and press enter. I get this error message…“Cannot edit PasswordEnabled: Error writing the value’s new contents.” So what do I do about this?

Hello; Malachai6669

If you boot in safe mode (Restart and Tap F8 after Manufacturer Logo Disappears) > Safe Mode

Then try again;

What OS are you running?


Running a modified version of Win 7 Ultimate. Will try safe mode and report back.

L.E.-So I tried in Safe Mode and worked perfectly. So that means the password is reset now?

Ok; Thanks


P. S. Translated by Google >>>>x<<<< …

Hello (again)! …
Can you please tell what the settings should be included, or rather, off - in short, to change, to not be blocked by a firewall connection attachment to the letter? …
Browser - Comodo Dragon …
Thanks in advance! …

could you explain a little more of what you mean?