Parental control doesnt protect CIS uninstall

A. THE BUG/ISSUE:

  1. What you did: Set a parental control password then tried to uninstall CIS. CIS was successfully uninstalled without password.
  2. What actually happened or you actually saw: CIS was successfully uninstalled without password.
  3. What you expected to happen or see: CIS should ask for the password. Previous build prompted for password.
  4. How you tried to fix it & what happened: N/A
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: N/A
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): CFW/CIS 5.10.x
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Set a password for parental control then uninstall CIS through the control panel.
  8. Any other information (eg your guess regarding the cause, with reasons): This bug isnt specific to my config. This is also reported by another user here.

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues): appended
  2. Screenshots illustrating the bug: N/A
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: N/A
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: appended

C. YOUR SETUP:

  1. CIS version, AV database version & configuration: CFW 5.10.x; Proactive Security
  2. a) Have you updated (without uninstall) from a previous version of CIS: Clean Install
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: Denfense +: safe mode, Sandbox: Disabled, Firewall: Safe Mode, AV:Not installed
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Pro 64-Bit SP1, UAC Disabled, Admin
  7. Other security and utility software currently installed: N/A
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: None

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again