Parent Injection Leak failure

I have recently started using Comodo firewall and still have all the default settings. So how come I failed comodos own Parent Injection Leak Test? It then recommended the helpful solution of downloading comodo as it was the only firewall to work straight from the box. I’m confused

Me too. I had the same experience with that test.



Can you please describe exactly what you see when you run the test? Before you start retesting make sure you delete the registry key “HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\AppCtrl\IPC”. It may be a case that previously you accidently pressed allow while remember option was selected. Deleting that key will eliminate this possibility. Remember to restart your PC after deleting.


Hmm, I’ve never done anything inadvertently before :wink: but I must have done that! I’m glad I got that out of my system.


I tried the solution above but it didn’t seem to work for me. When I run the test it just opens the results page and tells me my firewall failed, but it seems to pass as it doesn’t know what i typed in the test. Then bizarly about a minute later i get the pop up asking me if I want to allow the cpil file to run. More worryingly, the two times I have run this test has coincided with a complete shut down of my computers wireless capabilities. I can connect to mine or a friends wireless but it wont allow any traffic of any kind. But it still works over a land connection. Even after i install comodo it still doesn’t work so I don’t even know if its comodos fault. Then after a couple of days everything starts working again. Its working again now though but I ain’t running that test again as I like the firewall but I’ll have to go back to kerio if I have anymore problems.

Do you have some other security software installed? It seems to me that either you have another security product or your previous security product is not properly uninstalled.