Parameter is incorrect

I am getting an error when trying to send an email from Windows XP Outlook 2007.

The email cannot be processed.
Error: The parameter is incorrect.

Would you like to send the email unsigned and unecrypted?

My CSE level is set to medium so it should automatically send the email signed. It will only encrypt if I have the email recipients certificate. What bothers me is that it doesn’t say what the parameter is.

After playing around with it a bit, it looks like a problem when sending an email within my domain. Has anyone ever seen this? Were you able to fix it?

This is not something I’ve seen previously. Have you updated to the latest version? I suggest a fresh install.


Comodo SecureEmail not signing or encrypting email
System: Windows XP sp3, Outlook 2007 connected to local Exchange 2007 server, CSE v2.5.0.31 (installed 20100415).

CSE Settings:

  • Security State - Medium
  • Decryption Settings - Auto decrypt incoming
  • Certificate Update Emails Settings - Prompt for both Other’s and My email certificate
  • Certificates -,, GAL set to auto add

I am the only one in my domains that has a certificate.

When I create a New Email Message, the “Signature and Encrypt” buttons are already activated.
When I try to send an email to someone in my GAL or within my email domains, Only the “Encrypt” button deactivates when I press SEND, I get an pop-up that states “The mail can not be processed. Error : The parameter is incorrect. Would you like to send the e-mail unsigned and unencrypted?”

I don’t get this error whenever I send to outside domains. I am able to sign all emails for outside domains.

I do not see any errors within Microsoft’s Event Viewer related to Outlook or Comodo.

It definitely appears to be an issue within my own email domains.

If I set the Security State to OFF and manually activate the Comodo Signature and I DO NOT receive the “parameter is incorrect” alert. I am then able to send an email out to my domains digitally signed.

If I create an email and manually activate the signature and encryption, I am able to send with a digital signature, ONLY after I choose the “Send Unencrypted” button from the Encryption Problems.

If I set the Security State to Custom and to the following settings in the attached images, I can encrypt (using Single-Use) and sign to outside domains, but cannot to my domains.

Please advise on the next steps to troubleshoot. Thank You.

[attachment deleted by admin]

Seems like possibly Outlook not reading the certificate correctly or CSE not recognizing your logged into the Exchange Server.

Can you screenshot your Outlook Security settings (Tools >> Options >>> Security Tab). Are both email accounts on the exchange server and under 1 outlook profile or are they separate?

EDIT : Just reading through the user guide you need to be in Microsoft Outlook Only Mode for CSE to support Exchange Servers

In order to change your CSE Mode you need to run the Product Maintenance Wizard by doing the following:

To initiate the Product Maintenance Wizard, double click on the SecureEmail setup file that you originally
downloaded (this is named ‘comodose.exe’ if you downloaded the 32 bit version and ‘comodose64.exe’ if you
downloaded the 64 bit version).
After clicking ‘Next’ at the initial welcome screen the ‘Product Maintenance Wizard’ will open and presents you with
three choices. Click the following links to find out more about each option:
• Repair This Version
• Choose Operating Mode
• Uninstal

From there, click “Choose Operating Mode” then select "Microsoft OUtlook only then click next & Finish.

You’ll be required to restart your machine to activate the correct mode.

P.S. Your not running X64 are you?



I only have one account within the accounts section of outlook. It is the chad[at]

The chad[at] is the email address(alias) that I actually use in Outlook and people see when I send email.

When someone sends me an email to chad[at], it goes to a separate server for cleaning spam, spyware and viruses. Once that is done, the email gets forwarded to my chad[at]

chad[at] is the default email address in the exchange box that receives the email.
So, my true email address as far as the exchange server sees it, is chad[at]

I ran the setup again as requested and it appears that I am running in MS Outlook Only-Mode.
I’m running Outlook 2007, so I’m guessing you are wanting the Trust Center Security Info.

[attachment deleted by admin]

I tried running the latest version of CSE myself, there appears to be either some sort of bug or just something else that needs ticking as I was having a simular issue. I’ll as the other mods, PM the Devs and see if can figure it out and provide you with a solution. Should take less than a day for me to find a solution.


I seem to be suffering the same fate with regards to CSE. Mainly getting the Incorrect Environment Issue. I was getting the parameters error but renewing my certificate (signing up for a new one, my old was about a year old and wasn’t the new 2048 certificate format) seems to have resolved the Parameter messages, so far. (Remember to remove your old certificate before signing up to a new one.

I can get certificates to send fine only when in Network Mode and not in Outlook only so I seems there’s some sort of issue with the Outlook Only part of CSE.

Continuing to look into it.