Packets loss in skype

When comodo firewall is in the safe mode, send packets loss in skype video calls is about 35%-40%.
When firewall is disabled - skype works correcly.

Skype version: 5.0.0.152
Comodo Firewall: 5.0.163652.1142

Skype added as a trusted application. Nothing special in the firewall events log.

Any ideas? I tried everything I could think of, searched skype and this forums and still can’t solve the problem… ???

Try disabling Block fragmented IP Datagrams.

Already disabled.

Hey and warm welcome to Comodo forums kubuzoid!

and you have added skype in application rules (CIS —> Firewall —> Network Security Policy —> Application rules —> add —> browse)?

Will this help to solve this problem?

Enjoy your stay here at Comodo forums! :slight_smile:

Regards,
Valentin N

Thanks for welcome :slight_smile:

Yes, I already have skype in the application rules.

Rules for skype:

  • Allow All Requests
  • Allow IP In From MAC Any To MAC Any Where Protocol Is Any
  • Allow IP Out From MAC Any To MAC Any Where Protocol Is Any

and it doesn’t solve this packets loss?

Regards,
Valentin N

Yes, these setting were already added when I noticed the problem.

Have you tried this or this

Hope this helps

Jake

I tried to add this rule from the second post:

“allow tcp+udp OUTgoing only for skype”

(though I already added skype as a trusted application) - it didn’t help.

In the first post I find restrictions only.

In the attachment bandwidth graph.

Also I can reproduce the problem when I upload a file via skype. When firewall is on uploading speed below 20 kb/s, disabled - 700 kb/s and more.

[attachment deleted by admin]

Upgraded Comodo to version 5.3.175888.1227. Problem is still here.

Does anybody experience the same problem or it’s just me? :frowning:

can you give me a link so that I look how it is for me. I had once problem of getting logged in but it got solved when I added skype in application rules.

I am truly sorry that CIS is giving you hard time.

Give a last try by adding it in defense + rules (if it is there ignore what I wrote).

Regards,
Valentin N

Have you tried trusting your network?

Stealth Port Wizard > Define New Trusted Network > Choose your router ;

It’s weird because :: If you add it as trusted application it should be allowed unless of course you are running a hardware firewall that needs to be configured;

Hope this helps

Jake

Can you show a screenshot of your Firewall logs? They are under View Firewall Events.

Thanks for your help, but I still can’t solve the problem :frowning:

I tried to disable Defense+ and added a trusted nework.

In the attachment is a screenshot from the Firewall logs. These two events in the log were added during a test video call. During this call I disabled and enabled firewall several times, each time when I disabled firewall outgoing connection speed were getting higher (about 70-100 kb/s), when I enabled firewall speed drop to 10-15kb/s.

I can’t send any links because the problem exists only for skype outgoing connections (video calls and file transfers)

[attachment deleted by admin]

Have you tried to put it in global rules and see if it helps?

Regards,
Valentin N

I didn’t understand what to do.
For a test I added to the global rules “Allow TCP or UDP In/Out From MAC Any To MAC Any Where Source Port is Any and Destination port Is Any” as the first rule. The same effect.

here is how you add something. donät for get that this is an

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok

Now go to stealth wizard and select the first option

Regards,
Valentin N

Please check if windows firewall is on.

Tell us if that help.

Regards,
Valentin N

Windows Firewall was on, I stopped it but that didn’t help.

The correlation is evident. When Comodo Firewall is off connection speed is about 100 kb/s. just when I enable it I see an immediate drop to 10-15kb/s.

Most interesting is why the firewall affects the application when I added the applications to the trusted list and allow any connections for it.

I recommend you to install CIS. I will give more info how to do it properly tomorrow; I am going to bed now

Take care.

Regards,
Valentin N