Outlook Express, Hotmail, Not Signing - XP Pro'

I logged on to the Administrator account to install CSE.

When it asked if I would like to apply for the Certificate, I said Yes, and give it my Email Address etc…
(I clicked ‘Yes’ because I thought that it may not offer again (on my LUA) if I clicked ‘No’.)

After installation, I let it Reboot.

[b]EDIT: (Remembered!)

I logged back on as the Administrator in case it needed to finish-off the installation.

I Rebooted.[/b]

Logged on as a Normal User (LUA).

Checked for Email with ‘Outlook Express 6’.

Clicked the Link to collect the Certificate.

It Opened in the Default Browser (Chrome) and told me to use Internet Explorer.

Copy/Pasted the URL from Chrome into Internet Explorer.

It told me to run an Addon.

Then told me this… (Screenshot Attached)

What should I do, I have a Revocation Password if its necessary? Not sure how to use it though.

Thanks.

[attachment deleted by admin]

Just a bit more information (probably not needed)…

The first time I tried installing CSE, I was logged on as a Normal User (LUA).

I had my ‘Returnil’ System Protection On. (So nothing is Saved to the real HDD.)

And I used ‘MakeMeAdmin’ to install CSE. (Its like using ‘Run As’.)

CSE Crashed, and I got the old ‘Report this to Microsoft’ message. (Yes, it Crash ‘before’ offering me the Digital Certificate.)

So I just Rebooted (Returnil was On).

Note: This is the way I test all Programs before installing them for real.

Then I just…

… etc.

I still have the Video if you need it uploading to YouTube for a couple of days?

I don’t have a Video of the steps mentioned in my first post though. Didn’t think it would be needed. :frowning:

Thanks.

Question:

How do I use the Revocation Password?

I am presuming that I can simply Revoke my Free Digital Certificate for my Email Address, then apply again from my Normal User (LUA) Account?

Thanks.

You Need To Submit A Ticket From https://support.comodo.com/ To revoke Your Free Certificate

Hi J2045,

We reviewed your posts (Thanks for such detailed description of the problem!) and think that you have next problem:

  1. Your ordered certificate under Administrator account (your private key was generated and stored for this user)
  2. You have tried to install it under Normal User account (actually any different user to Admin) and you received correct error.

The possible solution for your problem:

  1. Login as Admininstartor
  2. Click the link to collect the certificate.
  3. Open this link in IE and certificate should be installed.
  4. Export certificate from Administrator Personal store to file.
  5. Import this certificate in Any User account you wish to :slight_smile:

I hope this answer will help to resolve your issues.
Feel free to ask any questions on CSE.

P.S. We’ll review issue with installation crash with “Returnil” and “MakeMeAdmin” run.
Thanks for the bug report. :slight_smile:

Regards, Eugene

  • Certificate Successfully Retreived and Installed into the Administrator account.
  • Certificate Exported (and Password Protected) and automatically Deleted from the Administrator account.
  • Certificate Successfully Imported to my Normal User Account (LUA) via CSE.

I tried Testing the Signing fuction by sending an Email from my Hotmail to my Gmail.

I am using CSE’s Default Settings for now, until everything is functioning.

The Email was Sent, Recieved, but not Signed.

I suspect CSE’s Ports are wrong and need to be configured Manually.

Could you please advise on what the Ports/Settings should be changed to? (Information provided below.)

This is how I configured Hotmail in Outlook Express… (A few Days before I installed CSE.)

Note that all other Settings are still at their Defaults.

[b]Use a POP3 server to add your Windows Live Hotmail account to Outlook Express[/b]
  1. In Outlook Express, click the Tools menu, and then click Accounts.
  2. Click Add, and then click Mail.
  3. Type your name, and then click Next.
  4. Type your full Windows Live Hotmail e-mail address, and then click Next.
  5. Enter the following information, and then click Next:
    In the My incoming mail server is a box, click POP3.
    In the Incoming mail (POP3, IMAP, or HTTP) server box, type pop3.live.com.
    In the Outgoing mail (SMTP) server box, type smtp.live.com
  6. Type the account name and the password for your Windows Live Hotmail account. Clear the Remember password check box unless you’re the only person with access to the computer. Make sure that the Log on using Secure Password Authentication (SPA) check box isn’t selected.
  7. Click Next, and then click Finish.
  8. In the Internet Accounts window, click the Mail tab, click the Windows Live Hotmail account that you added, and then click Properties.
  9. Click the Advanced tab, and under Server Port Numbers, enter the following information, and then click OK:
    In the Incoming mail (POP3) box, type 995.
    In the Outgoing mail (SMTP) box, type 25.
    Under both Outgoing mail (SMTP) and Incoming mail (POP3), select the This server requires a secure connection (SSL) check box.
  10. Click Close.

This is how I configured Gmail… [ YouTube Video ]

I did try experimenting with the CSE Ports, but no luck. CSE seemed to keep on crashing Outlook Express as it couldn’t seem to intercept. Maybe I need to Disable Outlook Expresses SSL?

[b]
EDIT 1:

I tried Disabling the SMTP SSL, it made no difference…

Tools > Accounts… > Hotmail > ‘Advanced’ Tab

EDIT 2:

Also tried Disabling the POP3 SSL… Same.

I’ve changed them both back to ‘SSL Enabled’.
[/b]

All CSE Ports are back at their Defaults again.

Once this is functioning correctly, I shall make a Video Tutorial with a temporary Hotmail address.

Thanks.

Quick update on what I have Changed from Outlook Expresses Defaults Settings apart from the ones already mentioned above.

I have just noticed that, when I Open Outlook Express, I get this Error… (I think it’s trying to Send the Hotmail which is still in my Outbox.)

The message could not be sent because the server rejected the sender's e-mail address. The sender's e-mail address was '********[at]hotmail.com'. Subject 'Test Sign', Account: 'Hotmail', Server: 'smtp.live.com', Protocol: SMTP, Server Response: '550 5.7.3 Requested action aborted; user not authenticated', Port: 25, Secure(SSL): Yes, Server Error: 550, Error Number: 0x800CCC78

After reading this ‘Post’, I have made the following adjustments to the Defaults Settings…

I went to:

Tools > Accounts… > Hotmail > ‘Servers’ Tab >

And clicked ‘My server requires authentication’.

Then ‘Settings’ and checked ‘Use same settings as my incoming mail server’, though this was already Ticked.

… It seems to have stopped the Error (it Sends successfully again), but made no difference to the ‘Not Signing’ problem.

Thanks.

SecureEmail will automatically import your port settings from previously configured mail accounts in Outlook, Outlook Express and Thunderbird. For all other supported and unsupported mail clients, SecureEmail will use the following default ports:

POP3 – port 110

SMTP – port 25

IMAP – port 143

It seems mine were not automatically imported.

Probably because I installed it via the Administrator account. Outlook Express is not configured to be used from that account. I don’t even browse the Web from that account if I can avoid it.

I think the best solution here would be to make it compatible with ‘MakeMeAdmin’, like you said in previously in this thread. :slight_smile:

[attachment deleted by admin]

I thought something like this would have worked… :-\

(See Screenshots.)

[attachment deleted by admin]

But instead I get…

(See Screenshots.)

And…

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'Hotmail', Server: 'smtp.live.com', Protocol: SMTP, Port: 25, Secure(SSL): Yes, Error Number: 0x800CCC0F

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: ‘NTL’, Server: ‘pop.ntlworld.com’, Protocol: POP3, Port: 110, Secure(SSL): No, Error Number: 0x800CCC0F

[attachment deleted by admin]

I’ve also tried this too of course…

(See Screenshots.)

But this way either makes Outlook Express crash when I Open/Launch it, or gives me Errors like…

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'Google Mail 1', Server: 'pop.gmail.com', Protocol: POP3, Port: 995, Secure(SSL): Yes, Error Number: 0x800CCC0F

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: ‘Hotmail’, Server: ‘smtp.live.com’, Protocol: SMTP, Port: 25, Secure(SSL): Yes, Socket Error: 10053, Error Number: 0x800CCC0F

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: ‘Hotmail’, Server: ‘pop3.live.com’, Protocol: POP3, Port: 995, Secure(SSL): Yes, Error Number: 0x800CCC0F

[attachment deleted by admin]

Changed CSE > Security > ‘Mode selection’ to ‘Off’.

I’m using the Free Digital Certificate in Outlook Express whilst waiting for a Solution to the ‘CSE Not Intercepting/Signing’ problem.

Thanks. :-TU

[attachment deleted by admin]

Uninstalled CSE.

Still able to use the Free Digital Certificate in Outlook Express. :-TU

Installed Mozilla Thunderbird. ‘This’ may come in handy for anyone who wants to do the same, if you keep your Private stuff on an Encrypted Partition (If you don’t, then you SHOULD!). :-TU

Note that when you import everything from Outlook Express into Mozilla Thunderbird, you may need to reconfigure your Ports and a few other Settings. And also import your Digital Certificates.

Hi,

To fix the problem you should disable SSL in your mail client (which
you have currently enabled, see HotmailPorts2.PNG)
Please note that the ports must remain the same and since when you
disable SSL the POP port will be changed to 110 automatically,
you’ll have to set it back to 995 manually.

You current settings as presented on your screenshots do not allow CSE
to intercept the mail traffic.

Meanwhile we are working on the issues (crashes and server errors) and
plan to fix it them in coming release.

I hope your issues will be resolved.
Thanks for your feedback.

Regards, Eugene.