Option "create rules for safe applications" makes CIS delete default rules.


I have noticed that the default rules were missing when CIS started asking me if I wanted to allow System to do this or that.
I wrote a thread and other members made me control my rules and we noticed the missing default ones. I had to manually create the rule for System applications.

We agreed that it was a bug caused by the fact that I had in some moment selected the option to “create rules for safe applications”.
Which is a paradox, because that option should make CIS create those rules automatically, while in my case it made it delete the default rules and I had to create them manually.


Could you perhaps provide your exact steps? A video might be very helpful.


I was not able to reproduce the problem.
I have no idea if it was maybe already solved with the new releases (I have now downloaded the last one).
Do you think it is possible that a product update has created this problem? I mean, uninstalling an reinstalling is clean, but a product update is not 100% clean, right? It leaves some files there (I suppose the Config files, my rules, etc) and updates only other ones, right?

Anyway, now I could not reproduce it.
I can give you the link to my other thread so you see what had happened and who and why suggested to open a bug report:

Apparently the rule set “windows system application” and all the relative rules were missing on my Comodo.
As I surely did not remove them, something must have happened.
Somehow the other guys are convinced that ithas something to do with the option to create rules for safe applications.

I have just opened the bug as suggested.
Your call if trying to reproduce it, try to see if it is related to product updates, or give it for solved with the new releases.

Sorry that I could not help more :frowning:

It is possible. In general, a clean re-installation is recommended (if you experience issues). #guide