/opt/COMODO/load_cmdagent.sh: 64: .: Can't open /etc/init.d/functions

I have uninstalled and reinstalled but cannot get it to install. I get the following error…/opt/COMODO/load_cmdagent.sh: 64: .: Can’t open /etc/init.d/functions

Then I look in /etc/init.d/ and find nothing called functions. Newby here. What have I done wrong? ???

Linux Mint 14 Nadia? Debian based from what I have read. I keep getting that weird error and it also tells me the kernel version is wrong. So I run setup again and still get /etc/init.d/cmdavd: 64: .: Can’t open /etc/init.d/functions at the end.

It tells me to /opt/COMODO/post_setup.sh and all goes well till the end where I get /etc/init.d/cmdavd: 64: .: Can’t open /etc/init.d/functions.

It also tells me to /etc/init.d/cmdavd restart and it says it cant open /etc/init.d/functions …I look in /etc/init.d and find nothing called functions… ???

OK…I tried something more. See below…

" sudo bash /etc/init.d/cmdavd restart
/etc/init.d/cmdavd: line 64: /etc/init.d/functions: No such file or directory
/etc/init.d/cmdavd: 64: .: Can’t open /etc/init.d/functions
Stopping cmdagent: /etc/init.d/cmdavd: line 141: killproc: command not found
The cmdagent failed to stop!
/etc/init.d/cmdavd: 64: .: Can’t open /etc/init.d/functions
Starting cmdagent: /etc/init.d/cmdavd: line 98: daemon: command not found
The cmdagent failed to start!"

■■■■■? ???

Well…I guess the only thing left for me to do is un-install this software and go with something else. There doesnt seem to be anyone else here. ???

It is possible that you have downloaded the incorrect version for your operating system. Try downloading the 32bit or 64bit version to match your operating system.

Download links:

  • RPM package, 32 bits[/b]


size: 24.3 MB (25,543,386 bytes)
md5: 7dc87a10f489a6d5db8b7c8b90f1fe5c
sha1: ed834b0d25dd1679a8bfb0a29a4bb006f752f3c1

  • RPM package , 64 bits[/b]


size: 24.7 MB (25,927,333 bytes)
md5: 98dba27aa5fa3bcc24d89a2f87190735
sha1: 3d1b4af1d6ca087ba4d30b17210433842ccf6581

- DEB package, 32 bits


size: 24.3 MB (25,547,968 bytes)
md5: 6626cd064079d26e9b0a391942cdea83
sha1: 6b58a5f2e876d42a2d555e290c88de708bf8dedc

- DEB package, 64 bits


size: 24.7 MB (25,923,010 bytes)
md5: f27829d950ccf701ef7cdb5c60f7fffe
sha1: 58c55547c2818c886a10992b17613696daf4c309

Installer references /etc/init.d/functions yet that is not where they are found…

Try this link:

$ ln -s /lib/lsb/init-functions /etc/init.d/functions

COMODO now starts when Mint LMDE logs you in 8)