Open port

In Comodo firewall I need to open UDP port 20001 and add an exception rule for an executable, no idea how to do either can anybody advise please?

I have an ethernet based HDD unit that runs great when Comodo FW is turned off, but access speed is vastly reduced with FW on.

Hi powerc,

Depending on your global rules, you need to allow this on both policies (global & application).
If you open the firewall policy and switch to the global tab add the following rule.

Allow (& log).
Source (define as needed)
Source port Any
Destination Any
Destination port, single 20001


Make sure this rule is placed above the rule that blocks all incoming traffic (rules are matched top to bottom).

Now you can add the same rule to the application on the other TAB or initiate traffic to your host that should trigger an automatic alert which you could answer…

Thanks for thre response Ronny. Tried your settings for the rule, and set all exe progs associated with the HD to “trusted” but still didn’t work. Even tried modifiying the port rule so that all IP and ports except destination port were set to “any” but still didn’t work. I’m obviously doing something wrong but just can’t figure it. With Comodo FW off and widows firewall enabled the disk runs great.

Anybody have any ideas? Anybody using Netgear SC101 with Comodo FW?

Any help much appreciated.

Can you please explain which of the two questions you are having issues with…

In regards to the speed issue;
What you can try is the following, go to Firewall, Advanced, Attack Detection, Misc and disable “block fragmented packets” reboot and see if that helps

The comms speed to the ethernet mounted HDD is the issue. I posted on the Netgear forum and was advised to open port UDP 20001 and enter an exception rule for the exe files. Following advice above I did just that but speed still very very slow when Comodo FW is enabled, but fine when disabled and when windows XP firewall is on.

I’ll try the “broken packets” setting and advise.

Thanks Ronny the Attack Detection setting solved the problem and I didn’t need to do anything with the UDP port as originally advised elsewhere. system now up and running with CIS enabled and all is good.

Thanks again for your help, much appreciated. :smiley:

No prob, glad you got your problem fixed :wink: