OOPS! "ERROR: Could not load C:\... (etc)... ...cfpres.dll" [RESOLVED!]


Nope! I imagine that this may turn out to be a bug, given that I’ve seen it mentioned elsewhere, on this board from Paradise (albeit, a confusing board from Paradise.)

I downloaded and installed V3 (onto my upstairs XP Home Edition machine.)

But, when I restarted, I was met by this…

“ERROR: Could not load C:\Documents and Settings\Administrator\cfpres.dll . Please check if application folder has this file. Aborting application.”

So, Comodo wasn’t loaded.

I checked in the reported folder and…there it was…“cfpres.dll”.

So, I thought that it had somehow become “unregistered”. I used the dll registration tool (at the “Run…” thingy) and was told, on the screen, that…although the dll had “loaded”, the operation couldn’t proceed, because there was (I think it said) “no entry point”?

So, I couldn’t re-register the dll, myself. OUCH!

So, I tried to just reinstall the V3, new try over old try (both V3, though). Nope! The prompt for uninstalling Comodo Firewall kept coming up, asking if I wanted to uninstall the existing firewall. I clicked “Yes” and - DING! No dice. I got some weird message telling me that I couldn’t uninstall.

Trying to install the old version gave the same results.

Now, I’m in a mess that I want out of, urgently!?

Now, because V3 isn’t running on the upstairs machine, and because I can’t uninstall it, I can’t use my main house machine to go online…at all?

I’m NOT TECHIE inclined - most who might know about my posts will know that, already. But, it’s essential that I get out of this mess - I have a lot of work to do. I need to be upstairs, on that machine, folks.

I want the V3 off and then to be able to REINSTALL it, again. As V3 installed without hitch on this downstairs laptop, I know that this is just a temporary bug.

In baby steps only, please…what must I do?

Only Comodo will do, for me, right now, but this has dented my confidence.

Oh, and…does anybody know the best way to stitch my poor Teddy’s head back on?


If you are able to boot into Windows then you can do a system restore:

Start>Programs>Accessories>System Tools>System Restore (pick a date before you installed CFP3)

If you are not able to boot to Windows then go into Safe Mode and try to uninstall it there:

Press the F8 key during boot to get there.


Thank you for your reply.

I’ll go and try that, now. I’ll come back and let you know how it goes, either later this morning (UK time) or during tomorrow afternoon / evening.

Fingers crossed.

Jasper, and others…

System restore would’ve been great, had I had the presence of mind and the common sense to have actually used it before installing V3, but…I didn’t, unfortunately, and V3 didn’t do any Restore point setting either, it seems.

So, System Restore isn’t my way out, sadly - and embarrassingly!

Uninstalling V3, as an option, has vanished from the Add/Remove Programs, also, because it makes NO APPEARANCE (!) there?

I used My Computer … Properties … Hardware … Device Manager … made hidden devices visible and I see that “COMODO Firewall Pro Helper Driver” is still in there. I wouldn’t have even known how to do that, except that I’d seen a thread started by a Member called “Vipes” and he had received the same on-screen message as I, even though the version number was different.

Should that “COMODO Firewall Pro Helper Driver” entry be taken out, now? If so, how?

When I try by disabling it, the V3 uninstallability continues, as does the un-uninstallability! When I try uninstalling the “COMODO Firewall Pro Helper Driver”, it just reappears, after the mandatory restart.

How do I stop Comodo Firewall Pro V3 from showing as (and thwarting my efforts as if it was) installed, still?

I just want somebody to give me a stream of SERIOUSLY DETAILED instructions on what to do to dig into the core of…wherever it is…and, enable me to rip it out by the roots! It would be unwise to assume, at any point during your typing, that I will automatically understand what you are telling me.

If the Techies, here, don’t know, then that means there isn’t a way and that means that V3 has a nasty bug, albeit a rarely seen bug, I’d guess!

I need the explanation to be broken down into the sort of detail that you’d usually apply to a lobotomised chimpanzee who is hoping to digest the ramifications concerning Schmidt’s Strontium 90 Random Event Generator’s influence on paranormal research into telekinesis, ESP and time travel!

Then, I have a chance of understanding it.

I have a GMER saved log file for that machine, taken during last night. I won’t post it because…not only is it huge, it may contain private details of/from my machine/software too techie-obscured for me to recognise, but easily discerned by any who understand GMER and the logs saved from it. But, I’d be happy to E Mail it to anybody in charge of this board who tells me that it’s okay to do so and whose E Mail address given to me matches their E Mail address as shown, on the board.




Look in C:\Program Files\COMODO\Firewall\Repair for the program called cfpconfg.exe

If you find it, try running it using the parameter -u

If you go to the Start Menu and select Run, enter

C:\Program Files\COMODO\Firewall\Repair\cfpconfg.exe -u

This should start the uninstall routine.

Good luck.




Mind you, it’s me writing this, so…you might believe it, after all.

I tried to do what is suggested in the post above this one, but I was getting bored and annoyed at the error messages.

So, I started thinking, “Corrupted File”!

  • I went downstairs, started up my laptop (where V3 is installed and fully functional).
  • I took the entire “C:\Program Files\Comodo\Firewall” folder and put it on a USB stick.
  • I came up here, deleted same folder on troubled machine.
  • I copied “C:\Program Files\Comodo\Firewall” into place, here.
  • Then, I did the advice thingy from the post above this.
  • It worked - I uninstalled V3 perfectly.
  • Then, I restarted, reinstalled V3 and - BINGO!




I’ve even uninstalled and reinstalled V3, again, twice, just to be sure that it wasn’t a fluke.

Many thanks to those who helped me!

Folder transplant or no folder transplant, I couldn’t’ve done it without you guys!

Ian. (:LGH)