On some boots all startup applications are sandboxed by CIS [M1100]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Every time
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:After I installed Comodo correctly, there was not any problem, but sometimes when operating the computer all applications operating in the startup be restricted and disrupted a lot of services in Windows, such as communication in the Internet
One or two sentences explaining what actually happened:
Sometimes when you run a my computer, is to restrict all applications that work with the startup, and these applications are trusted from Comodo
One or two sentences explaining what you expected to happen:
Not to restrict trusted applications that work startup, when I run the computer
If a software compatibility problem have you tried the advice to make programs work with CIS?:
NA
Any software except CIS/OS involved? If so - name, & exact version:
None
Any other information, eg your guess at the cause, how U tried to fix it etc:

dump cmdagent.exe

dump CisTray.exe

B. YOUR SETUP
Exact CIS version & configuration:
The problem occurs in two versions :CIS 8.0.0.4337 and CIS 8 BETA 2
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default configuration
Have U made any other changes to the default config? (egs here.):
No
Have U updated (without uninstall) from CIS 5 or CIS6?:
No
if so, have U tried a a a clean reinstall - if not please do?:
Clean Install
Have U imported a config from a previous version of CIS:
No
if so, have U tried a standard config - if not please do:
NA
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used
in real system win 7 x74 and virtualbox win7 x64
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=none b=none

[attachment deleted by admin]

Dear SD

Many thanks for reporting this issue.

I would be grateful if you would append your full active process list or Killswitch listing when this problem is occurring.

A dump of cmdagent.exe, taken using Killswitch, when the problem is occurring would be helpful too

Are there any other symptoms, for example is CIS continuing to consume hi cpu at that point?

Many thanks in anticipation

Mike

Done !

Hi SD

Sorry to trouble you further but if possible please record the Killswitch processes when the roblem is occurring. Please also open Killswitch in advance so at the ratings are showing - some are currently showing ‘analysing’.

Kind regards

Mike

I modified the first post

thanks

Thanks SD, but the Killswitch file still does not show all/most user apps being sandboxed.

Instead it shows some comodo processes running as unknown which is certainly strange but not what you are describing. Maybe of course it is what causes it!

Can you confirm that all/most user apps are being sandboxed?

Please append a Killswitch display showing this if you can.

A Killswitch screenshot is best as it will show the process tree.

[attachment deleted by admin]

Thanks SD, forwarding

In my own opinion, this issue is not caused by CIS but KillSwitch. If KillSwitch version is not 8.0.0.4337, you can try this:

  1. Close KillSwitch if it is running.
  2. Navigate to folder C:\Program Files\COMODO\COMODO Internet Security, and delete file killswitch.exe.
  3. Open CIS main UI → Advanced Tasks → Watch Activity, if a diagnostics window shows , click Ok on it. After diagnosing then the latest version of KillSwitch will be installed.
  4. Check the processes again whether those processes are still been sandboxed.

The problem occurs after running my computer, the problem is not related to the to killswitch because the problem occurred before downloading killswitch.
olso ,The problem occurred on more than Windows and the problem exists in a beta “2” version

Hmm yes above I note that its displayed on the APL above. Everything under explorere.exe running as limited.

But just for the record what is your Killswitch version SD?

Also have you changed the Auto-sandbox to sandbox as limited?

(Restraw reported this long ago BTW that’s why it is 1100).

Although maybe there are two different bugs…

Personally no I am not at all skeptical. But QA may not be able to replicate, so a video will help get it processed.

(I am unsure whether this is a new or a known bug, hence all the questions)

Could you sees if it happens with VirtualBox uninstalled? VB used to be a problem for CIS.

Kind regards

Moue

I finished the video-making, but unfortunately in the beta 2 version, the reason for this is that I come back if it tried to test the final version of the my real systems does Comodo isolating Screen capture program and thus prevent the program works correctly, but fortunately all the problems existing in the final version is matching 100 % of a beta version

Notes on this problem are as follows:

1-If I disabled automatically Sandbox, even after disabling and receive a message that the Sandbox already been disabled, but in fact when I run any application is restricted, whether trusted or unknown
2- Sanbox can disable automatic in one case, which is to close permanently and restart the computer
3-An important point is if I tried work “log off” and then enter the user account again Comodo works normally, but after the restart the computer back problem again
4-This problem had no bearing if the system is in an virtual or real system
5- Only problem occurs on systems that support the core X64

[attachment deleted by admin]

6-If I changed the Internet Security to Proactive Security or Firewall Security is no longer a problem But if I return to enable the comodo -Internet Security The problem back again

Thanks SD. In that case please append an export of your config as well.

Please mouse1, move the first video to my first post,also configuration file

[attachment deleted by admin]

Hello,

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version 8.1.0.4426) and let me know if this is fixed on your computer with that version.

Thank you.

This is actually not the same as 1100, as a) in the video many but not all processes are sandboxed b) they are sandboxed as Limited not FV although the sandbox is set to FV, and SD say this happens even if it is off.

So returning to the Bugs in tray for reprocessing.

Q, when you have time, please adjust description to reflect what is in the video and reprocess.

Many thanks

Mike

I think that the problem is not repeated again.