On Screen Keyboard always pops up on all form fields

Ice Dragon has just downloaded and installed. Now the OSK keeps appearing, even when set to “desktop” UI.

Very annoying. Most people would not keep using CID in this situation, it is so annoying!

The computer is a Lenovo Helix, that is a laptop/tablet convertible. O/S is Win 8.1 64 Bit and is being used in a desktop situation with a powered USB hub to drive large monitor and wireless mouse/keyboard.

It appears to be behaving correctly when the computer is used as a laptop without the hub, screen, and keyboard added on. The OSK would be a blessing in the tablet config, but in this desktop mode (with the hub etc.), it isn’t!

Please help, it’s driving me nuts!

Read this a few days ago hope it helps :slight_smile:


I too have that very annoying problem (not on my desktop)
My friend has a Surface Pro, and I installed IceDragon (the latest) for him.
It defaults to Tablet mode every time IceDragon starts (annoying big text and Tabs), and the massive Win 8.1 on screen keyboard appears (even when his keyboard is connected).
He just made me get IE11 into a half usable setup (I haven’t found all the things that need re-setting yet).
I dislike MS defaults in practically everything they release, so you could do me a favor, by advising how I could get his IceDragon to stop going into Tablet mode, and raising MS OSK, even when he has physical keyboard connected.
If we can stop that, I can get him back to using IceDragon (because I hate IE 11)

Thank you Dennis2 for your comment.

I reckon that idea would work. But on the other hand, that fix is just like the old saying “using a hammer to ■■■■■ a walnut”. I don’t use the tablet format very often, but it seems wrong to kill a basic machine function (the hammer) because of a bug in one piece of software (the walnut).

The particular machine has to go in to have a fan replacement, and I expect the supply of spare parts to be very slow. I am hoping Comodo will have a fix for this bug by the time the machine comes back fixed!

That said, if anyone has a suggestion to fix it in the meantime - I’m all ears!

I was dubious about posting the suggestion as it seem rather extreme, but though I would give you a choice :slight_smile:

I would also hope this is fixed soon aswell :slight_smile:

Thanks for the reply.


Until there is a patch, doing this worked for me:

[ol]- Open about:config

  • Change this value: ui.osk.on_screen_keyboard_path to ANYTHING that isn’t correct…
  • e.g. “C:\Program Files\un-Common Files\microsoft shared\ink\TabTip.exe”
  • When Comodo Ice Dragon is fixed, change this back to “Common Files”[/ol]

Fantastic suggestion! Thank you greggerca. I had to do a ‘double take’ to notice the “un-” - but that is just so neat, and so easily reversed later.

Worked for me.

Now I will have a real reason to read “Release Notes” for a while, until this is fixed!!

All the best :azn: