On reboot after install CIS hangs with hi CPU on congrats screen then goes slow


Well, this is my 9 th attempt to re-install CIS 7…and it fails once again…

This time the clean install stops immediately after the “Congratulations” screen

a. CIS 7 installer does not proceed any further
b. system reboot does not re-initiate/advance the installation process
c. clicking on shortcut will not start cis.exe
d. clicking on cis.exe returns the following error message:

   "Error while loading resources from "C:\Program Files\COMODO\COMODO Internet Security\Themese\defaults.set."
    Aborting application.

This type of installation issue is, without any doubt, directly/indirectly related to Restoring Windows 8.1 - either via Restore Points or the various other System Restore options!!

At this point I don’t think I can get either version 7 or 8 Beta to work on my system…which is less than 3 months old and has more than enough capabilities to handle CIS and Windows 8.1 (AMD A8-6410 w/6 GB RAM).

CIS 7 worked great, but ever since I used System Restore options it hasn’t installed nor worked correctly…

With the absolutely insane amount of time I’ve spent on these issues, along with other unrelated problems with Windows 8.1 quirks, I just don’t think CIS 7 is viable at this point in time (at least on my system/Windows 8.1).

Really, at this point it would be asinine to continue on…obviously something is seriously wrong…

Let me know if I need to submit another Bug Report on this one too.

[attachment deleted by admin]

Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

Unfortunately, I’ve done all of the suggested installation best practices - repeatedly - and they don’t work.

I’ve gone way above and beyond the suggestions by performing clean installs after system reset, refresh and restore. These attempts have failed also.

Safe Mode clean install does not work…

There is absolutely no software on my system that would be the source of the problems other than Windows. 8.1

Like I said, my very 1st installation of CIS 7 worked great, until I restored Windows 8.1. Since then,

  1. CIS 7 or 8 will not install correctly, and if they do
  2. CIS 7 or 8 will not function correctly…

Frustrating…I’ve spent days, and days, on this forum and tried everything suggested

Finally got CIS 7 re-installed, but not without quirky behaviors, after following all these steps:

  1. Safe Mode uninstall
  2. Ran CIS removal tool
  3. Ran Microsoft Install-Uninstall Troubleshooter tool
  4. Used Glary Utilities to clean registry remnants (approximately 20)
  5. Used Glary Utilities to delete leftover files (many files throughout AppData Local, Roaming, ProgramData… folders)

The installation proceeded in the correct manner, but the widget and CIS tray icon autostarts did not work. Applied qmarius’ registry fix.

The following quirky behaviors were observed after running the initial Rating Scan:

  1. CIS froze after a HIPS alert
    a. “Comodo Not Responding” box appeared directly over top of the alert box
    b. CIS freeze above could not be resolved - had to hard start the system
  2. After system reboot, there were several HIPS alerts:
    a. sounds were generated, but
    b. alert boxes did not appear
  3. Running an additional (5) separate Rating Scans - one directly after another - without opening any applications nor installing any
    software resulted in the
    a. identification of multiple new Unknown files that were not included in the prior scan (7, 3, 1, 1, and 2 files respectively)
    1. during both the 3rd and 4th Rating Scans, UIAutomationProvider.exe was identified as unknown - despite the fact that
    I had applied the Trusted action during the 3rd scan

Hi hjlbx,

Please use the required/standard format.

Thank you.

Should I include all the issues or just the Rating Scan issue in the Bug Report?

Make sure you used a normal uninstallation procedure. It’s not clear whether you used it or not.

Mmmm…sorry I wasn’t clear

Uninstalled CIS in Safe Mode
Ran CIS Removal Tool in Safe Mode
Removed remnant CIS registry entries
Removed remnant CIS folders and files
Clean installed CIS 7.0.3

A. CIS 8.0.4337 Installation and Start Up BUGS/ISSUES
Can U reproduce the problem & if so how reliably?:
Occasionally. I can not reproduce each at will, but they occur frequently enough to negatively impact user’s experience.

If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Clean install CIS 8.0.4337
2: Installation continues to stop at “Congratulations” screen
3: Upon system restart to complete installation system hangs at Windows 8.1 Start menu for 2 - 3 minutes
4: Cursor can move but moves extremely slowly
5: Cannot access desktop for 2 - 3 minutes
6: Once can reach desktop, Widget takes more than 2 minutes to appear
7: During this time cannot access CIS console for another 1 - 2 minutes
8: During all of this CIS’ CPU usage spikes as high as 90 % over a 3 - 5 minute period
8.1: When trying to access CIS console by selecting Widget bar, Comodo Internet Security Not Responding box appears
9: CIS adding files to Unrecognized File list upon system reboot without alert box/alert sound
10: HIPS generated alert sound, but no alert box; lag time in alerts and sounds or not appearing at all
11: Primary context menu does not appear when right-click on file path of item in Unrecognized File list…but secondary
context menu does (i.e. Trusted, Blocked)

One or two sentences explaining what actually happened:
CIS 8.0.4337 continues to not install properly or operate very well on a system with a restored or refreshed Windows 8.1 operating system.

One or two sentences explaining what you expected to happen:
I clean installed CIS 8.0.4337 and expected my system to be able to boot quickly to the Windows 8.1 Start menu, quickly access the desktop, for CIS to start quicker and the Widget to appear much faster, for much faster access to the CIS console, no CIS induced CPU load issues, to be alerted before files added to Unrecognized Files list, to see an alert box accompanied by the alert sound.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not applicable.

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how U tried to fix it etc:
All evidence suggests CIS’ update function as it exists in version 8.0.4337 is causing excessive CPU loading during startup.

Exact CIS version & configuration:
CIS 8.0.4337, Default

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have U made any other changes to the default config? (egs here.):
AntiVirus set to “On Access”

Have U updated (without uninstall) from CIS 5 or CIS6?:
if so, have U tried a a a clean reinstall - if not please do?:
Not Applicable; clean installation

Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
Not Applicable; clean installation with default configuration

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
(Restored/Refreshed) Windows 8.1 x64, UAC - Alert me when making changes to system, Administrator, no VM used

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a= HitmanPro.Alert b= HitmanPro.Alert, Windows Defender deactivated

Dear hjlbx

Very sorry that you are having this problem.

To determine this issue we will need a full OS dump if you can manage that.

Guidance on how to achieve this is here:

If on trying these instyructions you find you cannot induce the manual BSOD as requested, please say, as this will suggest it is similar to an issue already reported.

Thanks, mouse1

Next few days…

Thanks, that’s great.

No BSOD was ever experienced during the issues cited in the Bug Report.

No I understand. I am suggesting you manually induce a BSOD so you can get a full system dump.

A less dramatic alternative would be to dump cmdinstall.exe and CIS.exe using a right click on the processes in Killswitch (both instances if there are two). But you might find that difficult if the system is using high cpu.

I realise this all takes time, but unfortunately normally QA will not process issues relating to hangs without dumps as they are difficult or impossible to replicate, and without replication cannot be diagnosed.

Many thanks in anticipation


Hello mouse1,

When I reinstall CIS 8 I will get:

  1. KillSwitch process list
  2. cmdinstall.exe, cis.exe, and cmdagent.exe KillSwitch dumps
  3. screen recordings using BlueBerry (flashback video [.fbr] format ok?)



Yes that would be great, thanks. Please make sure:

  1. The Killswitch list is a screenshot, taken when the freezing problems are occurring (as far as possible), and with all ratings showing (ie not still analyzing), also CPU and RAM

Many thanks for doing that


Everything can be found here:

NOTE: See additional video zip file showing an additional error upon reinstallation at bottom of thread.

Forum Moderator or Comodo Staff PM and I will transmit decrypt Key.

The above info is identical to that provided as part of the following Bug Report:


As all of these separate Bug Reports are tied in together the separate threads really should be merged.



[attachment deleted by admin]


The issues are no longer occurring with build



Thanks for the feedback. Moving to resolved.