Old Versions of CIS Premium, 5.9, 5.8, etc...

Is it ok for someone to use old versions of CIS Premium, or do old versions become unsupported after a while?

yes you can use older versions if you wish. They will be supported for a while. Version 3.14 stopped getting AV updates when v5 was released so version 5 should get AV updates for a while.