Old CBU files

A little over a year ago, I backed up my Windows 7 machine with I believe Comodo Backup 2.x and created a few CBU files about 130GB in size. I then switched my computer to a linux distribution.

Recently wanted to evaluate those files to see if there was anything in them worth keeping. I brought up a Windows 7 box and installed the latest Comodo backup software (version 4 I believe). I then tried the mount the CBU files. CB hung on the “Please wait…” screen (during what I guess is a catalog process) for about 15 mins. Windows then informed me the the exe stopped worked and ask if I wanted to close it.

I then found an RC 2.0 CB version and installed it to see if I could mount the CBU files. It returned the error saying they were corrupt.

Is there anyway to mount these files?

It’s normal that the mount operation takes more time (could take up to 1min/GB which in your case might mean ~2 hours) because backups created with 2.x version don’t have an indexation inside, so when mounting a backup, the indexation is built by analyzing the entire file.

But, the program should not crash.
Please try again, and if it crashes please create a dump file. Instructions can be found here.

Once we determine the cause of the crash we can say for certain.
You can also try to restore the backup to a disk/partition which is equal in size or greater than original.


I’ve uploaded the crash dump to the ccloud.com site you specified.


We found the problem. It will be fixed in next release.

Until then you can press “Restore Now” in resore step 1 which will restore your backup to original location with default settings.

Or you can use command line and scripting.
You can export to script a restore operation that does work in restore step 3, to avoid writing the script from scratch.


Thanks for the help. I’ll wait until the release. I’m not interested in restoring all of the data, just inspecting it for select items I may need/what.