OE: Message could not be sent. An error has occurred.

I’m new to Digital ID’s so here goes…

I’m using OE 6 on a Win XP Media Center Dell. Have received and installed my free certificate (thanks) but when I hit send (having clicked the Digital Sign icon) the computer waits a while and then issues this error message: “Outlook Express - The message could not be sent. An error has occurred.”

Sending messages without the ID work fine. I’ve checked and my email address is the same as on the certificate, and the certificate listed in the Store is marked OK.

Any advice? Thanks in advance.

I wanted to update my earlier post based on my reading of many of the other suggestions I found on these forums.

I’m running Win XP SP3 with all current updates. Also, I’m running Norton Internet Security and Spybot S&D. I went into NIS and saw that I was scanning both incoming and outgoing emails. In the hopes that this was the problem, I turned off these scans. Unfortunately, no change to the issue—I get the same error message when trying to digitally sign and send an email.

Any thoughts on what I might try next? Thanks. ???

Hi,

Have you checked out the knowledgebase on email certificates?

you can find it here:

Garry

Dear SSL Guru,

Thank you for your reply. Yes, I had read that section and tried all the ideas I thought were relevant. I have since taken a second look and tried them again. No luck, yet. Also, I Googled and Binged my problem and tried options others have suggested around deleting Sent Items, Deleted Items folders and cleaning out my Inbox, turn off virus scan and firewall, etc. Same outcome.

I decided to export my certificate to my desktop (for safe keeping) and then download it again from the Comodo server. However, when I tried, it said “The associated private key cannot be found.” This reminded me that when I originally downloaded the certificate I got the 0x80092004 error which said that a) the computer and browser had to be the same as when I ordered the certificate (they are), b) the private key was missing (I couldn’t tell), and c) I had already downloaded the certificate (this was my first time).

When I went into Internet Explorer anyway, the certificate seemed to be there, so I thought I was home free. Now I’m thinking the private key might be the problem. (It said this certificate is ok, though.)

Also, some interesting observations that might be relevant:

In OE > Tools > Options > Security > Digital ID, I found my Windows Encryption File System Certificate but NO Comodo certificate; however,
In OE > Tools > Accounts > Properties > Security, I found the Comodo Certificate associated with my email account.

Out of curiosity I went to Run > MMC > Console Root > Certificates and under Personal found BOTH the ERS certificate and the Comodo certificate. Not sure why the discrepancy, but this (latter) seems to be the right place for both. I also found the Comodo certificate under Trusted People.

I thought the private key would come from Comodo and be put on my machine; if so, do you know where it might be located? Or, if Comodo uses a private key that is already on my machine, where should I look to find it or generate a new one? (Someone noted that “make private key exportable” should have been selected when originally applying for a certificate—I’m pretty sure I did select that as well as the higher level key size.)

Perhaps, ideally, I could just remove all of this and start again with a clean download from Comodo (if this is possible)?

Thanks for taking the time to read my post and offering suggestions. Hopefully the above additional information can shed some light on my issue.

Hi,

The private key is held on your PC…not by Comodo.

It is possible to start again, you would need to contact support and ask them to revoke the existing certificate. Once done you can apply again.

Please submit a ticket at: http://support.comodo.com/

Garry

If you successfully Exported your Certificate to your Desktop (with the Private Key), then there is no need to Download it again.

Just Import the one you have on your Desktop.

You should Save it onto a ‘Flash Drive’ or a ‘CD/DVD’ too, then lock it away somewhere safe.

Hi J2897,

Thanks for the suggestion. I was unable to export my certificate with the private key (it said that the private key wasn’t there), so I suspect I ■■■■■■■ up when I first applied or when I tried to download my certificate.

I’ve since asked Comodo to revoke my current certificate and I will reapply (carefully, this time) for a new one.

Another question though, should I turn off: Norton Internet Security (2009) antivirus and firewall, Spybot Search & Destroy (1.6.2), and PGP (the free 9.1 version, no email or certificates) before I download a new certificate? Or, maybe change some setting in Outlook Express itself? Just wondering if some setting on my machine is inhibiting proper download.

Thanks,
Psychlone

a) The computer and browser had to be the same as when I ordered the certificate. b) The private key was missing. c) I had already downloaded the certificate.

There is something missing from here which I think Comodo should add to the Message for future use, which is:

a) The computer, [b]user account[/b] and browser has to be the same as when you ordered the certificate.

It should also be included in the CSE Help File.


Yes. First, Enable the standard Windows Firewall just to be on the safe side. In fact, I would Stop/Disable anything which is not needed; close all Programs/Applications.

Maybe its possible to install the Digital Certificates in Safe Mode; I’m not sure.

Do you use VMware?..

If it was me, personally, I would use a Virtual Machine. Install Windows XP (Default Settings), and use that to recieve the Digital Certificate for the first time. Then, Export it to the Desktop (with the Private Key ‘Exportable’), and Save it onto a ‘Flash Drive’ or a ‘CD/DVD’.

Once you have it backed-up, you can try to Import it to your usual Machine as many times as you like.

Here’s another Comodo ‘Forum’ which you may wish to read for information on Digital Certificates.

Here’s also some ‘Notes’ I made when I tried Outlook Express. Not sure if they will be of any use to you.

Thanks, J2897:

I think the issue was on my end; probably wrong account, but I’m not sure. In any event, I contacted Comodo to revoke my certificate and try again. They were amazingly fast and I was up and running within 20 minutes. This time I made sure I didn’t log out of OE or my computer until I had downloaded my new certificate. I also turned off Norton antivirus and firewall.

I have successfully exported my certificate to a thumb drive and loaded it onto another computer (Samsung Mini) and it works fine.

Again, thanks to all for your suggestions. ;D