Occasional BSOD (DRIVER_IRQL_NOT_LESS_OR_EQUAL) on Boot [V6][M662]


[ol]- BSOD (DRIVER_IRQL_NOT_LESS_OR_EQUAL), cmdguard.sys

  • Can U reproduce the problem & if so how reliably?:Random, sometimes happens during boot
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a:Reboot computer
    b:Sometimes a BSOD will occur
  • If not obvious, what U expected to happen: NO BSOD
  • If a software compatibility problem have U tried the conflict FAQ?: I have read the conflict FAQ. I didn’t find there a decision to my problem.
  • Any software except CIS/OS involved? If so - name, & exact version: Avast 8.0.1497
  • Any other information, eg your guess at the cause, how U tried to fix it etc: This only occurs if CIS is set to Proactive Security. With it disabled the BSOD does not happen.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware):
    Full Dump (kernel memory dump)


[ol]- Exact CIS version & configuration:Comodo Firewall 6.3.294583.2937, Proactive Security

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Defense+=Safe, Autosandbox=OFF, Firewall=Custom Policy
  • Have U made any other changes to the default config? (egs here.): Of course yes, I added rules for applications in Firewall and Defence+. CIS is in proactive security.
  • Have U updated (without uninstall) from a CIS 5?: No. I have the clear installation of CIS 6 (CIS 5 was uninstalled before).
    [li]if so, have U tried a a clean reinstall - if not please do?: I have the clear installation of CIS 6.
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: Tried
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7, SP1, 64bit, UAC=on, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS: a=Avast 8.0.1497, b=None

Thank you. To make sure there are no difficulties for the devs in terms of identifying and fixing this issue, please also attach your process list, diagnostics report, and configuration file to your first post.

Also, just for reference, this is a new BSOD, whereas an older one was reported here, but as the BSOD type changed a new report was eventually created as well.

If you have any questions please feel free to ask.

Thank you.

  1. What do you mean by “process list”? This is a BSOD, OS isn’t fully start yet than it happens.
  2. What do you mean by “diagnostics report”?
  3. Really strangely! Why do you ask about “configuration file”!? The problem is on the drivel level!
    The IRQL_NOT_LESS_OR_EQUAL bug check indicates that a kernel-mode driver accessed paged memory at DISPATCH_LEVEL or above. What about “configuration file” do you speak? :slight_smile: Use full memory dump(kernel memory dump)! It is quite enough.

I think developers have a fully information - kernel memory dump. They need only cmdguard.pdb and source files and windbg will show a line code with the problem, and all other info to identify the problem there is in the crashdump. What else you need?

BSOD happens at startup that’s why all needed info is only in the kernel memory dump.

The second crash dump: Full Dump #2 (kernel memory dump)

In general what I asked for is required, but as these processes should be in the kernel memory dump anyway, I suppose they may not be required for this specific report. Thus, I will forward this to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I will hope they fix it.

What about this BUG?
Why so long?
You have ALL what you need to fix it!

This issue will hopefully be fixed for the next release of CIS. The most recent release was just a Hotfix release to allow Windows 8.1 users to continue to use CIS.

I believe the next version should include many bug fixes. I’m sorry that has not been released yet.


still random BSOD(DRIVER_IRQL_NOT_LESS_OR_EQUAL) caused by cmdguard.sys during boot
full(kernel) memory dump

Please, fix this!
I don’t want to use another firewall but already think about this…

Really I already ready to pay some money, if not too much :slight_smile: because jump to another firewall will take much time for studying new product and it’s settings.

Do you have such possibility? :slight_smile:

Thanks for checking this. I’ve updated the tracker.

This issue will hopefully be fixed for the next major release of CIS. The most recent release was still another release with a few hotfixes, among which was fixing the cancellation option for PrivDog.

However, I sadly have no knowledge of specifically when this release will come. Hopefully it will be soon.

Thank you.

The problem happens when Avast is installed. So this is the conflict of cmdguard.sys with Avast drivers. But how can it be if cmdguard.sys is the Sandbox Driver? I turned off Auto-Sandbox in principle from the begining of using Comodo and I have not any manually added programs to the Sandbox list.

Can developers answer something about this here?

I have made some tests:
I deleted Avast and Comodo, installed Avast, next installed Comodo. After I tried to switch default config from Firewall Security to Proactive Security - the BSOD happens and already when system is working not during boot as before.

Why Proactive Security configuration makes BSOD?

Thank you for testing this, and providing additional information for replication. I have updated both the first post and the tracker.

Thanks again.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.