Nvcpl.dll must've been altered + log (certain games stopped working after)

Hi,

I have just reformatted my pc and thinking of re-doing it.

Just after my pc had gotten that clean format I installed comodo cis premium. I heart comodo and think its one of the best free anti-virus programs out there. However, I recently found out why a few of my games have stopped working… because of comodo.

The first thing comodo does after install is to alter ncvpl.dll. In what sort of way I have yet to find out, all I know is prior to comodo my age of empires games worked. After comodo installation they STOPPED working, not even starting up. I believe nvcpl.dll has a lot to do with that.

My question obviously is, how can I undo the nvcpl.dll damage??


http://img834.imageshack.us/img834/20/nvcpldllageofempires2do.jpg

CLICK the link for a larger screencap!!

Thanks for your time!

David


Nvcpl.dll is actually an Nvidia component. It’s this dll that’s responsible for providing the extra stuff you see in display properties, related to Nvidia. So, my guess is that your games are failing to start for some other reason. Any chance you can provide some more detail. maybe pick a particular game, such as AoE, and describe what happens when it’s launched.

It would also help if you would describe your configuration details for D+/sandbox/firewall etc.

First of all I want to thank you for replying to my post. It doesn’t happen often when I join a forum that I get someone willing to help, let alone try and figure out a solution.

As for the problem itself;

Indeed that is what I figured out when browsing on the internet. Also I’ve come to the conclussion that it is not the alterning of the nvcpl.dll file that caused the error.

I have re-formatted my computer again in the meantime and installed comodo again. However, before I Restarted my computer as requested I changed a defense + setting. I changed the non recognised files from partially limited to blocked. And as expected, my comodo after restart blocked the nvcpl.dll file + another related one. This time however he didn’t change anything about it and just blocked them. After which I configured them reliable.

I ought my problem solved after this and started up age of empires 2. Apparantely it still didn’t work… at least I figured that it isn’t nvcpl.dll causing the problem but a major setting in comodo itself.

As for the settings I changed nothing in particular aside from mentioned above.

I experimented for my own however and disabled all settings in defense + (the last tab) and disabled sandbox.

It’s even more frustrating then when I close comodo age of empires 2 will still not work! Before comodo installation it worked fine like I said, but app comodo alters something that interrupts my game.


http://img714.imageshack.us/img714/7139/errorsettingscomodoaoe2.jpg

Edit by Dennis2: removed the uploaded to well known image hosting site message

The error message states : " age of empires 2 doesn’t work anymore."

So what do you make out of this?

Greetz and thanks for your time so far.

David


Hallo. Welkom op de Comodo forums.

I am with Radaghast in assuming that sandboxing of nvcpl.dll of Nvidia’s control panel is not related to the problems you are facing with your games.

Please start with setting treat Unrecognised Files to Partially Limited again and not to blocked. Also tick everything under Defense + Instellingen → Beveiligingsinstellingen. That way we will have a default and level playing field.

Next step is to start your affected games one by one. When you see in the Defense + logs (View Defense + Events) that a game gets sandboxed unsandbox it by moving it from Niet Herkende Bestanden to Vertrouwde Bestanden. Then see if that helps or not.

When that does not help try the guidelines in App. is not working correctly, but does not seem to be s/boxed. What to do? [v5].

Can you also post a screenshot of the D+ logs or around the time you are starting the effected games?

Alright, looks like I’m getting some progress, I did as you suggested.

This is the error I got when trying to start age of empires 2 (never had this before, usually it just disables from the start).

After I ticked in ‘application make exception’ and continued it still wouldn’t run. However, when I try to run aoe2 now I get these errors in my D+ log.

http://imageshack.us/f/818/shellcodeinjectionaoe2.jpg/

The log says its a shellcode injection. And If I’m correct in any way with this then I know old computer games often relied/used buffer overflow.

In the log I’ve already tried adding it to “vertrouwde bestanden”, but still the game won’t work. And I still get the original error message.

Other games seem to work fine, its just aoe2 that forfeits to a start-up.

So that’s about it for now. Hope you can help with it.

regards,

David


The catch is that AOE 2 creates another executable which also trigger the BO alert. You need to add that executable to the exceptions as well.

Is the name of other executable that AO2 creates the same name each time or does it change? It it changes we need to make a more generic exception for BO alerts.

Hi,

I don’t know what exactly changed between moment 1 and 2 but apparantely age of empires 2 seems to work now.

The aoe2 exe file had already been added to exceptions in defense+ shellcode. However I wasn’t able to play it. I turned my pc off for a few hours and restarted, then tried playing aoe2 again.

When it worked I was absolutely baffled. What had changed during this time?

Does comodo perhaps need time to refresh a cache or something alike? Because it seems like it, it didn’t work hours ago and now it suddenly does.

I find it strange mainly because I can’t see what fixed this problem!

The game works, probably due to adding an exception rule… I just can’t see why it didn’t work then and finally does now.

I’d like to thank you guys nonetheless for helping me out with this! This is one of my favourite games and I just have to play it every now and then! Thanks guys :smiley:

I am glad it got fixed. Let us know if you have another hiccup.