Number of unrecognized files is reported wrong [RESOLVED]

The summary page keeps reporting that I have 572 unrecognized files, but if I go to the list it is empty. If I install a program or otherwise add files to the unrecognized list, the count rises appropriately. If I then move those files to trusted, or delete them, the count again drops, but never below 572. I’m not sure how this got stuck, but can someone help me get it unstuck? A registry key or ini file where this info is stored perhaps?

Just for the record, it doesn’t seem to really affect anything… Defense+ and the rest of the firewall seem to operate normally. But its obviously not right and I’d like to fix it.

I’m running Windows XP SP3 with all the latest hotfixes and patches. Comodo Firewall reports product version 5.3.181415.1237. Clicking the update button reports that I’m up to date and the diagnostics button reports no problems found.


Hi Virago, welcome to the forums.

What Mode do you have Defense+ set to? Does the Unrecognized count survive a reboot or cfp.exe (CIS’ front-end GUI) restart?

Hi Kail,

I’ve actually had this problem for quite a while, I just finally got annoyed with it enough (and had the free time) to come here and try searching for an answer. The count has survived hundreds of reboots and even three or four software updates to the firewall.

Defense+ is running in Clean PC mode. If I change to some other mode, then change back to Clean PC mode I get a dialog box that tells me “You have 572 unrecognized files, do you want to see them?”. Clicking yes takes me to the list which is completely empty. Clicking on Purge simply gets the response that all files are valid (even though there are no files).

About the only thing that I can think of that I haven’t tried yet is a complete uninstall/reinstall. That just seems like a ‘nuke them from orbit’ solution to what is admittedly a rather minor problem. I’d really rather not lose all my settings and have to start over again, and I suspect that anything that saves my setting will also save this file count.

For what its worth, I’m new here but I’m not a computer newbie. I’m perfectly comfortable editing my registry or using a hex editor as long as I know what it is I’m trying to edit.

Thanks for your help,

Hi, can you give us a dir listing from this path?
C:\Program Files\COMODO\COMODO Internet Security\database

It could be that the stuck counter is caused by one of the files in there…

I suspect that if you answer NO to the question “You have nnn unrecognized files, do you want to see them?” when you switch Modes, then it should empty the list and, hopefully, reset the counter as well. But, something is certainly wrong there.

Hi Ronny,

One file listing coming up.

                              Creation          Last Access
Name               Size       Date       Time   Date       Time   Attri
c:\Program Files\COMODO\COMODO Internet Security\database\
                   1,517,562  2010-10-05 18:16  2011-03-20 14:24
pending.h              4,616  2010-10-05 22:48  2011-20-03 14:27  -a---
pending.n                  2  2010-10-05 22:48  2011-20-03 14:27  -a---
submit.n               1,136  2010-10-05 18:18  2011-20-03 14:28  -a---
vendor.h              80,560  2010-10-05 18:16  2011-20-03 14:02  -a---
vendor.n             428,588  2010-10-05 18:16  2011-20-03 14:02  -a---
vendor.sha           408,020  2010-08-28 13:39  2011-19-01 10:13  -a---
white.h               49,492  2010-10-05 22:48  2011-19-03 17:12  -a---
white.n              545,148  2010-10-05 22:48  2011-19-03 17:12  -a---

Not sure if I tried that before or not, but I just did now and it makes no difference. The only thing that changes is that it doesn’t show the list if you answer no and it does if you answer yes. Either way it still says I have 572 unrecognized files. And just to set the record straight (I was going from memory before), the actual message reads:

You have Unrecognized Files in your list.
Would you like to review them before going into Clean PC mode?
               YES                       NO

Just in case it matters, the dialog that shows the (empty) unrecognized files list also has another tab labelled “Submitted”. There are 8 files listed in that tab.

I’d move the pending.* files in safe-mode to an other folder to see if that resolves the issue after a normal reboot.

That seems to have done it.

Safe mode wasn’t necessary. The files were neither locked or open, so the system let me move them without complaint. After a reboot the count then read 0. I added a file to the unrecognized list and the count went up to 1, then after deleting that entry it went back to 0.

My great thanks to both Ronny and Kail for your quick, accurate, and professional assistance!

Glad to hear it’s working as expected now.