Novice Newbie & Printer Sharing Problem?

Hello,

I am new to this forum and am hoping that someone can help me ???

My problem is that I am having having real difficulty in trying to network my printer. I have been dealing with Epson support. They are telling me that ultimately my problem lies with Comodo.

“The problem regrettably, resides with the XP Host machine. The ‘List this Printer in the Directory’ option on the XP Sharing tab is probably not present, due to settings of your Firewall. If I may suggest, I would disable it completely while you are running tests. If we can’t get this [Windows] option to appear on the XP driver, then we will not be able to network your printer”.

I have tried to find a reference to my printer in Comodo with no luck ??? Should I see a reference? I am confused.

Can someone please explain, in easy to understand words, how I go about resolving this issue?

Many thanks

Cat

Have you tried adding your network as a trusted zone?

Hi Pepoluan,

Thanks for your reply.

Can you tell me how to do this please?

Thanks

Cat

Cat,

There are two steps to this process:

  1. Go to Security/Tasks/Add a Zone. Give the Zone a name. Use the IP address fields to define the range for this zone (it will automatically default to the entire subnet). You want to ensure that you include the IP addresses for the Host PC and (if applicable) the networked printer (if the printer is attached to the Host, it won’t have a separate IP; if it’s attached to a hub, it should).
  2. Go to Security/Tasks/Define a New Trusted Network. Use the Zone you created. This will add two rules to the Network Monitor in CFP (Rule IDs 0 & 1). The first will Allow IP Out from Any to Zone. The second will Allow IP In from Zone to Any. This will allow unimpeded communication/traffic across that zone, to/from your computer/client/printer/host.

I don’t know what your setup is - how your printer is actually connected, which just makes a minor difference; probably not a bid deal. However, if the printer is not yet networked, you may run into some difficulties. Keep the following in mind:

  1. While trying to get the printer set up, you can move Security Level to Allow All
  2. If the printer is attached to a Host PC, you can ignore item 1 here; just make sure that the host PC’s IP address is used for your Zone.
  3. If the printer is connected thrua a hub or router and will have its own IP address, you may either use item 1 here, or use the default IP range for the Zone (as this would be certain to include the eventual IP address of the printer) - later you would want to edit the Zone to close in that IP range to only what you need.

If any of this confuses, just let us know; we’re here to help.

LM

Hi LM,

Thanks for your reply.

In answer to your question, my printer is attached to my host pc. I am trying to network my printer.

I have successfully followed your instructions in step 1. However, I am confused about what I enter/select for step 2? The first field is Specify Application, and if I browse, I see a Firewall folder? Can you help? The second field is Specify Parent Application, what do I enter here?

Your help is really appreciated.

Cat

Tnx for the clarification, Cat.

Step 1 is to Add a Zone which would include the IP address of the Host PC. This is done within CFP under Security/Tasks/Add a Zone.

Step 2 is also done under CFP - Security/Tasks/Define a New Trusted Network. At this stage you will use the Zone you created - see attached screenshot. You’ll see there I am showing two items in the drop-down menu; if there’s only one only that one will show; this will be the Zone you’ve just added.

Doing this will allow communication two occur across the two (or more) PCs. If you have Comodo on each, you will need to do this on each one.

Here’s the next question for you, though… If you set Comodo’s Security Level (found on the Summary Page of the Firewall application interface) to Allow All, can you connect through from the Client PC to the printer?

The reason I ask that is, before being able to set up Comodo’s Firewall to work correctly, the computers must already be properly configured, and the printer connection working. If they’re not, you have to do that first…

Thus, if the computers and printer still need to be set up apart from Comodo Firewall, set the firewall to Allow All (on both machines), or turn it off. Once everything is workign, then the firewall can be turned back on.

LM

[attachment deleted by admin]

Hi LM,

Sorry for the delay in replying to your last message.

Thanks for further explaining the two steps and for the screen shot. I will check this on my OS and get back to you.

In answer to your question…no, I’m unable to connect through from the Client pc to the printer. Please refer back to my first post for reference.

Does this mean I cannot proceed with step 2?

Your help is appreciated.

Cat

Cat, this is only of importance IF you can’t connect from PC to printer with the firewall out of the loop.

In other words, you can do either of these:

Right-click the “notification tray” icon for the firewall, and select “Security Level” then “Allow All.”

OR

Right-click the notification tray icon for the firewall, and select “Exit” then follow the prompts to shut it down.

After doing EITHER of these (you don’t have to do both) try to access the printer.

IF you cannot access the printer at that point, this means:

The Windows Networking/File & Print Sharing/Printer/Etc is not properly configured. Until this is set up correctly, we cannot configure the firewall to allow it. While trying to set up the printer connectivity, you will need to leave the firewall disabled per one of the steps I just gave you (you might want to turn the Windows FW back on during that time, to give you some protection).

IF, however, you CAN access the printer with the FW disabled, that tells us for sure that the FW rules need to be changed, and we can address that.

LM

Hi Lm,

Thanks for your latest message.

I have decided to start at the beginning with printer sharing. I have so much info from yourself and Epson that I am getting confused :-\ :-\

Will get back to you if I need help in the future.

Thanks

Cat