Notifications settings from 'File List' are not remembered after GUI exit[M1509]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Always
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Open CIS File Lookup
2:Right click on a safe file such as explorer.exe and select “Lookup”
3:Click on the close button
4:When CIS tells you the file is safe and has been moved to your local certified files database, mark “Do not show this again” and press “OK”.
5:Press “OK” on the Advanced settings window
6:Repeat steps 1-3 and 4 will occur again.
One or two sentences explaining what actually happened:
CIS doesn’t save the “Do not show this again” mark for certified trusted files.
One or two sentences explaining what you expected to happen:
CIS to not tell me that the files are moved to the certified database when I already received this message.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A
Any software except CIS/OS involved? If so - name, & exact version:
None
Any other information, eg your guess at the cause, how you tried to fix it etc:
None

B. YOUR SETUP
Exact CIS version & configuration:
8.2.0.4591, Proactive Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS Disabled, Autosandbox Enabled w default policies, Firewall Enabled, AV Enabled on Default Settings
Have you made any other changes to the default config? (egs here.):
Yes, HIPS disabled w/ Enhanced Protection Mode Off and Adaptive mode off
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No
if so, have you tried a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
No
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 64bit, UAC Enabled (Default), Admin Account, Not a Virtual Machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

[attachment deleted by admin]

Any update on this bug report? Why is it not processed?

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

I’m no longer getting this issue with 8.2.0.4703 on Windows 10.

In that case, I will move this report to “Resolved” section.
Thank you.