not sure if CIS is working...doesn't start at starup

I had a few questions for you if you don’t mind.

1-We have another computer in this house, and it’s not mine, but a family member’s. I went on it the other day, and noticed that comodo said ‘‘at risk’’ which as you know means it hadn’t been updated autmomatically(even though it says to check for updates every few hours) anyway, after updating it, i restarted the computer, and noticed that comodo no longer starts automatically at boot. basically the little comodo square with the secure button doesnt appear in the right hand corner after a restart. i have to click the comodo icon for the comodo square to appear. I tried cleaning the one piece of malware on that computer(subsequent scans with herd protect mwb, and cis were clean as well as the autorun/killswitch) but it still is not opening at startup. I even uninstalled version 7, and updated to the new cis 8…but still it doesnt run when computer restarts…i have to open it myself. any idea what the issue here could be?

2- My second question has to do with when i uninstalled cis 7, and reinstalled cis 8(fyi i also deleted the cis 7 registry in cccleaner). After downloading cis 8 from your link in ‘‘installing comodo firewall on gizmosav site’’ I got through the setup prompts about running comodo’s dns, and using yahoo. Then it was that green circle screen where it gives the percentage as far as being installed. when it reached 50 or so percent it said corrup file and couldn’t install it. I then went back to the download and clicked it again from internet explorer to try again, and it worked that time. I eventually had to do a system resotore anyway, and had to restore back to when cis 7 was on the pc, and had to do the above all over and the first time I tried installing cis 8, i still g ot that corrupt file message, but second time it worked. idk if the firewall is working. The first time when it said corrupt file, i still got that congratulations for installing comodo message.

3- My third question is simple. Something weird is going on with that computer regarding opening programs. CCcleaner in particular has randomly started giving me problems. When i double click it, it won’t open. IT WORKS IF I RUN IT AS AN ADMINISTRATOR, bt not if i just double click it…this has never happened. any idea what this could be from?

4- last two questions… first is, how does rkill work if it hasnt been updated since august? Isn’t malware updating everyday? Second, if i use rkill does that mean i dont need to run a scan in safe mode, and is it better to use rkill for a scan with cis, or does cis work better with active malware? rkill said there was no malware fyi.

5- lastly, i cant find how to get to safe mode in windows 8.1…when i press f8 i dont see the same safe mode screen under recovery options as on my 8 computer.

sorry for all the questions, pick and choose what you want to answer. .main concern is the fact that comodo isnt starting on its own, and i dont want that computer to be reinfected.

Locked for double posting