Not Starting Virtual Kiosks/Win8 x64 Pro [V6][M168]

It seems that on both my PC’s the virtual kisok is very easy to not start.and it is very easy to have many problems fixing it
If you double click the Kiosk icon on the security widget it starts two virtkiosk.exe processes which you can see running in killswitch.So you get stuck with the virtual kiosk screen loading on your screen and it just says loading virtual kiosk and you never get to the kiosk. So then i tried sign out of windows 8 and it says this process won’t quit do you still want to sign out and i say yes i do.
i get the login screen, sign in again. Then reset sandbox and the try to a single click on the virtual kiosk and it works most of the time. Some times this requires a reboot. I think a new feature to fix this is to not allow double clicks on the security widget virtual kiosk icon. or any icon on the security widget. this will prevent hanging kiosk’s and double browsers/processes. But truly a single click should only be recognized for the kiosk icon. this will stop problems like this. I will say though once the kiosk is running and you say switch to windows from the kiosk. then double click back on the virtual kiosk icon on the widget it instantly loads the kiosk back since it is already active in the sandbox. So just be careful how many times you click the kiosk icon on the widget when trying to load it or you will not get to the virtual kiosk.
Maybe a rule in CIS 6 that says only one virtkiosk.exe processes is allowed to run at a time would fix this. problem is unless you know things about a computer, killswitch and resetting the sandbox you will never get to the kiosk. Let me know your results or is this a windows 8 x64 issue? I have an amd and an intel and they both act the same so i am sure it’s not a windows issue.

It hung twice after two signouts and sign back in with win 8 pro x64.
i reset the sand box and all is well attached are the killswitch logs i forgot
the screen capture. next time i will capture the screen.
these logs show two virtkioske.exe running…
Update 12/20/2012 my amd pc kiosk hung again here’s the screen shot attached with two virtkiosk.exe processes
This problem on either PC is so intermittent i can’t pinpoint it to fill out a bug report!her goes the intel a few minutes later this time i had some thing running. outlook 2013. but it was on the intel not the amd.
screen shot and killswitch log attached.thats it for no more chasing like this

[attachment deleted by admin]

You can still fill out a bug report, indeed we would very much appreciate it. Just say the problem is intermittent, and under step to replicate say that you cannot, or state anything that makes occurrence more likely.

Will leave here for one more day

Best wishes


0 Summary of issue:
I am sure it’s a hard to pinpoint intermittent bug

  1. Diagnostics report:
    Diag File attached,Killswitch Log attached and screenshot

  2. Full Comodo product and version:
    COMODO Internet Security 6.0.260739.2674

  3. Operating System:
    Windows 8 Pro x64

  4. Configuration:
    Configuration: Proactive
    Firewall: Enabled (safe mode)
    Defense+ HIPS: Enabled (safe mode)/Enable Enhanced Protection Mode is on
    Defense+ Behavior Blocker: Enabled (limited)
    AV: Not Installed
    Block Fragmented IP traffic check
    Enable Anti-ARP Spoofing checked
    Using Comodo Secure DNS settings in Network Card Dns Settings

  5. Other Software Installed
    Avast!7 FreenAntivurs current updates as of today.
    Super Antispyware with real time protection active/lifetime license current as of today
    Malwarebytes free mode no realtime active
    HitMan Pro 3.7.0 build 182 free version no realtime active

  6. Step by step description to reproduce the issue:
    I cannot give and exact method it just happens at random times on two different PC;s
    It occurs by launching the virtual kiosk. Try launching the virtual kiosk. the kios welcome screen comes up but it just says loading forever on the welcome screen.Launch killswitch and you will see two virtkisok.exe running. you have to sign out of windows 8 an sign in. reset the sandbox and this 90% of the time it works. some times a reboot is required.

What does this mean?
Virtual kiosk does not launch and cannot be used. The average user won’t be using the virtual kiosk 100% of the time.It maybe related to the number clicks allowed on the virtual kiosk icon on the security widget.I have not proven this.



[attachment deleted by admin]

CIS6 2674 Virtual Kiosk won’t Run. Get two virtkiosk.exe processes and kiosk welcome screen displays and says loading virtual kiosk forever.
This should summarize the issue. May be best to write it after drafting the issue report. A good title makes sure the right mods and the right devs look at the report

A. Virtual Kiosk won’t Run. Get two virtkiosk.exe processes and kiosk welcome screen displays and says loading virtual kiosk forever.

  1. What you did: It’s intermittent I can’t exactly recreate the problem. It happens on two of different PC’s. I thought it might be the number of times you click the virtual kiosk icon on the security widget
  2. What actually happened or you actually saw: I saw the Virtual Kiosk Screen displayed and It said loading Virtual Kiosk But the welcome screen never went away and I never got in to the virtual kiosk
  3. What you expected to happen or see: I expected to enter the virtual kiosk function of CIS 6 and surf some webpages that have banking information
  4. How you tried to fix it & what happened: I signed out of windows 8 and signed back and reset the sand box and that fixes it. Every time this happens the sand box must be reset and sometimes a reboot is necessary
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?:
    No there is nothing else running when it occurs. I did have outlook 2013 opened one time it happened.
    It happens on both PC’s
  6. Details & exact version of any software (except CIS) involved (with download link unless malware):
    Avast!7.0.1474 Free Av version, Superantispyware 5.6.1014
  7. Whether you can make the problem happen again, and if so exact steps to make it happen. My best guess since it so intermittent. Reboot the PC and get a fresh start, Use ice dragon, open a word document, then use comodo dragon. Surf some pages and work on some documents open a pdf file in adobe, maybe zip a file or two then try the virtual kiosk from my experience it only happens after working on different things after a fresh reboot.
  8. Any other information (eg your guess regarding the cause, with reasons):NO

B. Files appended. (Please zip unless screenshots).Screenshot, Killswitch Log, And Diagnostic file
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active process list. If accessible, required for all issues:
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: 6.0.260739.2674 Proactive
  2. a) Have you updated (without uninstall) from a previous version of CIS:NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):Defense+ Ticked enable enhanced protection, Firewall Settings, ticked block fragmented IP Traffic, ticked enable anti-ARP spoofing. Enabled Stealth Ports
  5. Defense+, Sandbox, Firewall & AV security levels: D+= SAFE, Sandbox= partially limited, Firewall = SAFE, AV = Not Installed.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 8 x64,UAC Off, Administrator level account
  7. Other security and utility software currently installed: Superantispyware 5.6.1014, Avast!7.0.1474 Free version
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box):NONE, But issue occurs on two different PCS both running Windows 8 x64 pro, UAC OFF, Administrator accounts

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


I am used to The virtual kiosk not coming upit’s a regular thing almost. usually 75% of the time the first time i try try to launch it, it just brings up the screen Virtual Kiosk…with the spinning circle saying virtual kiosk is loading.
I sign out of windows 8. sign back in reset the sandbox and launch virtual kiosk and it works.

It worked! I just signed out signed back in. reset the sandbox and launched the virtual kiosk.
ran comodo dragon in the virtual kiosk and and logged in to the comodo forum and wrote this message.
The best answer for this problem is after using the computer for an a while doing torrents with utorrent 3.2.3, using water fox, comodo dragon, snagit, checking webmail. Something about the sandbox goes stale. with a fresh sand box the virtual kioski works fine. I will start to reset the sandbox then launch virtual kiosk and report back the results to further prove it.attached is killswitch log while virtual kiosk is successfully running, and a kills switch log view with the sandbox processes view. and a screenshot. Remeber these are logs for when it is working! Maybe you can look back at my above bug report killswitch logs when it was not working and compare the differences and figure out some thing. But from now on i will reset thy sandbox before going into the virtual kiosk and report back my results!

[attachment deleted by admin]

Thanks for the update, much appreciated.

seems like others are resetting the sandbox before open the virtual kiosk and it’s working.
it’'s worked everytime for me also so far. Reset sandbox, launch virtual kiosk.

Reset the Sand Box then launch The Virtual Kiosk. That’s the work around and fix for now until you get the bugs out. 100% every time it works. i don’t even bother thinking otherwise any more. it’s a reflex now to reset the sandbox then launch the virtual kiosk.Until the next build that’s the recommendation.

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Hello. I’m using 6.2.282872.2847. Can’t start Virtual Kiosk. But I can see virtualkiosk.exe file started in Task manager. But nothing happens. Also I can’t start Virtual Comodo Dragon. This also start virtualkiosk.exe and nothing happens too. It is clean install. All AV, HIPS, Firewall enabled. What should I do? Help me.

Does resetting the sandbox just before you try to open the Kiosk allow the Kiosk to open?

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.