Not so happy

On the advice of PC Magazine I installed the Comodo firewall. If you do anything but gaming, it appears to work fine, well except it won’t work with AVG Free antivirus, so I had to switch to Avast. Unfortunately, I have had great difficulty trying to play games with the Comodo Firewall. The problem is that the firewall blocks any programs that try to access the internet, and waits for you to allow or deny the program in the Comodo pop-up. Ghost Recon Advanced Warfighter, and Battlefield 2 were trying to contact the server, and in the process prevented me from tabbing out of the game to submit the answer to the firewall. I know I can tell the firewall to allow the games by opening the Applicattion Control Rules, and browsing to the program executable, but that doesn’t appear to work very well. I did that with both GRAW, and BF2, but still wouldn’t allow the program to contact the internet, causing the program to lock up the whole computer.

Hi, sorry to hear about your trouble. If you would like, you may try posting here in the forum or go here>,2314.msg18198.html#msg18198

Someone is always willing to help. It may be a simple setting issue. Can you take a screen shot of your settings and post it here? Also, I want to mention, when you set rules, the physical order or top to bottom order matters a lot. If your gaming rule is at the bottom of the rules, you may want to move it up to the top.


If you do a google for " “gamename” + ports" You should be able to find all the ports required for the particular game. Create app and network monitor rules for these ports before starting the game and you should be right.

Hope this helps,
Ewen :slight_smile: