not saving rules from popup query when "Network Security Policy" window opened

  1. Open “Network Security Policy” rules window.

  1. Wait for popuing window asking for new rule. Make the rule here with “remember my choice” option.

  1. Close “Network Security Policy” rules window, open it again and you’ll not find the rule, created before in step 2.

OS: Windows 7 SP1
CIS version: 5.3.50343.1237

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

To Dennis2: edited.

We really would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format. You can copy and paste the format from this topic.

Thank you

Dennis

Did you read what i wrote? Or you just always paste two phrases in this forum?

Yes I did read it.

Example of what your bug report should look like.

[b]TOPIC TITLE
Unlimited access alerts generated for program defined as an installer/updater

The bug/issue

  1. What you did: Applied the Installer/updater policy to myprog.exe, rebooted, then ran myprog.exe
  2. What actually happened or you actually saw: Unlimited access alert
  3. What you expected to happen or see: No alert
  4. How you tried to fix it & what happened: Ticked ‘don’t ask again’ on the alert, did not work
  5. If it’s an application compatibility problem have you tried the application fixes here?:
  6. Details & exact version of any application (except CIS) involved with download link: myprog.exe v. 5.1.005 (Beta), www.xyzwprog.com/download
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. a) Check Myprog is installer/updater in Computer Security Policy ~ D+ rules b) run Myprog from Start menu ~ All programs ~ MyProg c) Get Unlimited access alert d) tick don’t ask again and press allow e) close program f) Re-start Myprog from same location g) get Unlimited Access alert
  8. Any other information (eg your guess regarding the cause, with reasons): D+ malfunctioning under load - cpu usage was high at the time.

Files appended

  1. Screenshots illustrating the bug: Appended
  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: Appended
  3. A CIS config. report or file: Appended
  4. Crash or freeze dump file: Not applicable

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.1000.1135, 6770, Proactive config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Yes
    b) if so, have you tried reinstalling (if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: Yes
    b) if so, have U tried a preset config (if not please do)?: Yes
  4. Ave you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security level: D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, None in XP, Admin account.
  7. Other security and utility software installed: CAS
  8. Virtual machine used: Vmware player[/b]

That bug that i’ve discribed doesn’t require all this information you’ve mentioned. It happens in any configuration. It can be described in one sentence. Developes will spend much more time reading this template you’ve wrote than reading one sentence and understanding what did user reported.
It’s like writing an article about grammatical mistake in the translation in the software. It’s not discreetly.

Thanks for help, but 99% of us will not want to describe all as in your example. Better not to write here anymore. You may not approve all our bugreports, but that’s in your interests let developers know about it.
Anyway thank you.

Sorry you feel unable to supply a bug report in the require format.

This bug format was decide on after discussions with the Staff to provide all the needed information in one post, without the Staff needing to ask repeat questions for the information they need to replicate the bug.

I was not involved in these discussions, all I have been asked to do is make sure the format is followed at all times.

Thank you

Dennis

Unfortunately we do need this issue to be reported in the full right format, and with all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do edit your post to create a complete issue report in standard format, and PM an active mod, we will of course consider moving it to verified reports.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.

Dennis