Not Getting AV Update

Hello,

I couldn’t get the AV database update, in the last 2-3 days. Only 30% of it is being downloaded and it stops there…

Can somebody help with this issue, please? I’d highly appreciate it.

Hi, floriana

Try to open Firewall → Common Tasks → View Active Connections and check if the cmdagent.exe is downloading the updates.

Thereby you will check if it really hangs or just downloads the updates slowly.

Actually the rate of update process on 30% means that updates are currently being downloaded, then it moves to 50% and starts to be applied.

I am having the same problem, after an initial install on a vista PC. Hangs on 30% for about 10-15 min and then states that it cannot connect to the internet and to check internet settings. Could not find any internet settings that were blocking this action though because all of the windows security is off.

What version of CIS are you using Marvin?

Problems with the initial update in particular are plenty on the Comodo forums. Most of the time it is only because of the amount of time it takes to download the 100MB+ at a rate that is way below the speed of the ISP connection.

There are a couple of things that could be done to help.

  • Have a status window for the download only indicating the size of the download and its percentage completed

  • Provide a direct link to the latest database file in a compressed format or even as a self install package

I suffered similar issues where cmdagent could not download the update. After several retries it worked.

Cheers

Hello, I’ve just installed free version of CIS (complete install, version 3.12.111745.560) but have a problem with updating AV database. When I try to run AV update it starts, then after about 5-10 seconds it shows 5% and immediately goes to say ‘failed to update… check your internet connection and try again’.

If I run system update from miscellaneous tab it appear to run as normal and it says no updates available.

Can someone help/clarify what’s going on please?

Thanks.

Update: I’ve had a look around comodo program folder and run cfpupdat.exe which found some updates and downloaded them and installed them succesfully. However AV still reports as never been updated… and I still cannot run AV update… it fails as per above.

Welcome to the forum mikosh :slight_smile:

Please check Miscellaneous / About to find out your virus database version the latest is 2642

Dennis

Thanks for the welcome Dennis2. Database is now 2642 because I did as ‘endlessjoy’ suggested in this https://forums.comodo.com/anti_virus_help/virus_update_database_faled-t46090.0.html thread.
First time around (after I set Comodo Internet Security Helper Service as instructed) I did the update and it asked for a reboot after which it did not appear correct but I did it again and it worked.

Thank you ‘endlessjoy’!! His instructions again:

Try updating the Comodo Internet Security Helper Service (control panel, admin tools, services, right click on “Comodo Internet Security Helper Service”, properties). The logon Tab for the Service should currently show Local System Account and Allow service to interact with Desktop. Set This Account with your Logon ID and Password (+Confirm) and then reboot