"Not functioning properly"

Hello! I’m using COMODO Internet Security for a long time… well probably since it was released. Yesterday, I saw a new icon of comodo in tray which never appeared before (pic attached). System status says that Defence+ is not functioning properly. I must notice it is turned off, and it always was this way, because I don’t use it for a long time, but never had such a problem. A ran the diagnostics but it tells me in the end that everything’s OK though. What may cause this? Thanx.

[attachment deleted by admin]

It would be a great help if you can give us a few details so that we can help you. What OS are you using for starters?

Windows XP Professional SP2
Also I have to mention that this issue happens not after each time Windows starts. If I reboot PC, it gets alright. But next time the same story repeats.


Try this simple Steps:

-Uninstall CIS
-Perform DISK CLEANUP (then restart)
-Restart again after Checkdisk is done

and Install Fresh copy of CIS


[Windows FIREWALL is TURNED-OFF anyway?]

I am seeing this exact same problem! Using Win XP Professional SP 3.

I will try the above steps and report back.

I tried the above steps and it was fine for a while, then occured again this AM.

I uninstalled and reinstalled the latest version (3.13.121240.574). Working OK for now, but this is not the first time or version this has happened with.


Have you tried disabling your WINDOWS FIREWALL?


It happened again this AM.

I confirmed Windows Firewall is NOT on. Comodo says everything is working, but the icon in the system tray has the No symbol.

Any other suggestions?

Try updating to the latest version. Run the updater under Miscellaneous → Check for updates.

Perhaps you need SP3.

Quit a few problems disappeared when my XP Home edition was upgraded from SP2 to SP3.

XP is fairly notorious for problems with the notification tray.

Even with SP3 I still had to reduce the start-up services.
Icons may fail to appear if they arrive a bit late on start-up.

In the good old days of Comodo 2.4 the icon had a colour which reminded you whether the firewall was active or disabled - that was the idea.
In practice Comodo might deliver it too late and it would not appear.
Alternatively it might launch it before it had finished initialising etc. and for a few seconds the icon might indicate “disabled” before it achieved “active” - and sometimes XP was too quick and closed the window for notification tray updates before Comodo achieved “active” so the rest of the day Comodo appeared disabled - until I right clicked the icon and refreshed its status.


I am trying the latest version. We’ll see what happens.

P.S. I am on XP SP 3.