Not blocking internet connections under some circumstances

And after clicking download nothing happens and a minute later I am returned to the main page without the download starting.

Stupid technology… life is so much better without it.

I’ll try to fill out the bug report because Comodo is simply not blocking internet connections. This couldn’t be more serious, and should be addressed in a matter of hours, not days or weeks.

Regards.

The bug report format seems too complex and cumbersome, so I’ll leave here as much relevant information as possible. If you wish to keep the program in its defective state because of a bureaucratic procedure, that is up to you. Alternately, you are free to convert the info herein provided into the desired format yourselves.

I used Utorrent yesterday, turned off the PC for the night, and turned it on again this morning. I am using “Custom Ruleset” with Utorrent not defined so that every time I start it I used to get the alerts requesting permission for it to connect to the internet. Previous to the last Comodo update it worked flawlessly for a long time this way. As I said, I started Utorrent again this morning after the PC along with the ISP modem were unplugged for the night, but because of the delay notification error, the alert only appeared some 10 minutes later. However in the meantime, Utorrent is uploading and downloading freely! As you can see, while waiting for the alert to be accepted or denied the program is not blocked:


http://s13.postimg.org/kmks1f1dv/image.jpg

After I agree to allow access more sources connect and the torrent resumes at greater speed:


http://s28.postimg.org/4ug5es6fd/image.jpg

This is my program version:


http://s29.postimg.org/g0i7xnyyb/image.jpg

I updated from the immediately preceding version from within Comodo itself after receiving the message that a new version was ready to be installed, am using Windows Vista 32-bit. Other security programs, Avast and Avira free antiviruses. Everything worked well before the new Comodo version.

I wonder if your bug could be related to this:

https://forums.comodo.com/format-verified-issue-reports-cis/sandbox-delayed-response-even-after-sandbox-is-manually-reenabled-m931-t99879.0.html;msg722747#msg722747

I’m very sorry but your bug may not processed and tracked by QA unless you report it in the bug reports section using the standard format.

This could be an important problem, so please do report it if you can.

Please note this facility is staffed by volunteers who give their time for free to help Comodo keep it’s software free. It would be really great if you could give 15 mins to help us in this way.

Best wishes. Mouse.

I merged your topic with the release topic to provide it with more visibility for Comodo staff. I also stated this in my previous post.

Could you try importing and activating a factory default configuration and see what happens? It will help us to determine whether your configuration has gotten corrupted or not in the updating process. The factory default configuration can be found in the CIS installation folder. When importing it give it an appropriate name like CIS Proactive Configuration New. This will prevent overwriting an existing configuration.

Let us know what it brings.

Finally I downloaded the program again from here as referenced by another user above:

and installed it by double clicking on it without further ceremony. The computer restarted twice and now it is working again. I thought I was getting an old version, but on the “about” page it says it is this same one 7.0.315459.4132. I only installed the firewall and disabled all other components and options. The alert delay error has apparently been solved as I am getting alerts for all programs anew, and instantly so, like it used to be. I’ll try again the Utorrent error later and report. At this time I’d rather go back to my studies of Greek, Arabic and Sanskrit, and make up for all the time I wasted on this.

Regards.

Well, even though the delayed notification bug was resolved by reinstalling the program, the Utorrent one was not. Utorrent is still able to establish some connections even if denied access by Comodo, and even after a night has elapsed with the computer turned off. I surmise this affects torrents which had previously been granted access. I’ll try with a new torrent later on and see if it can connect even if refused permission.

Your program has a humongous security hole and you should address it with urgency, official bug report or not. You have all the substantive information I can provide you.

Goodbye.

"What other security programs do you have installed and which ones did you have installed in the past?

With programs you had installed in the past please run their removal tools to make sure no traces of them are left behind. Sometimes a driver or service gets left behind and can cause strange and unexpected effects. You can find a list with removal tools here: ESET Knowledgebase . Let us know if that changes the situation or not.

I formatted my hard drive some 6 months ago and reinstalled Vista from zero, and the only security programs that have been on it are Comodo Firewall, Avast, Avira and Windows Defender. I am not willing to uninstall any of them however.

I suspect this problem is not exclusive to me. Perhaps you could attempt to replicate it? With Utorrent undefined in the Custom Ruleset, start a big torrent with many sources using Utorrent, let it run for a while, stop Utorrent and close the program, and then open Utorrent again with the torrent running and see if data are being transfered before you authorize it to access the internet in the Comodo alert.

What programs are currently installed alongside CFW?

I suspect this problem is not exclusive to me. Perhaps you could attempt to replicate it? With Utorrent undefined in the Custom Ruleset, start a big torrent with many sources using Utorrent, let it run for a while, stop Utorrent and close the program, and then open Utorrent again with the torrent running and see if data are being transfered before you authorize it to access the internet in the Comodo alert.
Comdodo Firewall will, if I recall correctly, remember decisions for the Windows session. My question now is to see what happens when you reboot after you closed down uTorrent.

Those mentioned above, Avira and Avast free versions.

As explained earlier, even after a whole night had elapsed with both the PC and modem turned off, when turning them on again and starting Utorrent but BEFORE authorizing it to connect to the internet on the Comodo alert, a few sources would connect and transfer data.

I will try this again tomorrow with the new install, but given everything else I doubt the result will change.

Hi Guys

I have moved this to the bug reports section, partly in the hope that a bug report can be created by someone else experiencing the bug, if not the OP, partly as it may be more visible to QA if it’s in the right place.

I hope that’s OK

If someone can make a bug report it will processed within one week, it will be allocated an appropriate priority, it will tracked by mods, and you will receive status updates.

If it turns out to be as serious as it seems, it really is the quickest way to get this addressed.

So please do create a format compliant report if you can.

Best wishes

Mouse

I am very sorry you are having this problem.

I have checked through this trace, and can see two possible explanations.

  1. You have some CIS setting/rule set otherwise than to defaults
  2. There is an interaction between the security programs you have installed and CIS
  3. There is some form of OS-specific behavior occurring. For example Win 8.1 and CIS have had a few issues.

Obviously there are other possibilities but I think we probably need to eliminate these first.

We could analyze the first if you were able to specify all firewall settings/rules you have changed. Screenshots of settings and all your rules screens would be very handy.

To determine the second for sure unfortunately you will need to follow Eric’s excellent suggestion and completely uninstall the other security programs. You could try disabling them completely and rebooting, but that is regrettably not a certain method.

To determine the third and to replicate we’d need your OS version

All these issues are of course dealt with in the issue reporting format and standard process, so I hope maybe in retrospect you can see its value, and will create a report in standard format. If not then regrettably after a while this report will be placed in non-format reports, and may not be processed by QA.

If I have missed any information your have supplied I apologize, but please understand it is difficult to scan a long topic for information, which is again why we have the format.

Best wishes and many thanks in anticipation.

Mouse

Here are pictures of my configuration:


http://s17.postimg.org/3u73xt7h7/image.jpg


http://s17.postimg.org/ov1qwh0d7/image.jpg


http://s17.postimg.org/6xcfexbtn/image.jpg


http://s17.postimg.org/821w6k8wr/image.jpg


http://s17.postimg.org/dwqheabrv/image.jpg


http://s17.postimg.org/3p7y1vpjv/image.jpg


http://s17.postimg.org/sh7k946qj/image.jpg

About disabling my other security programs, that is something I won’t do. They have never bothered me a provide me an excellent service. Besides, Comodo not being too trustworthy at the moment, I won’t take the risk of leaving my computer unprotected. Finally, neither the Avira nor avast versions that I’m using feature firewall functionality that could conflict with Comodo, and all three have coexisted in harmony for years and years on my PC. I really doubt the issue lies here.

As I specified earlier, I am using Windows Vista 32-bit.

About the standard bug format, maybe it could be made more user friendly so that folks like me can employ it.

Finally, here is a shot of Utorrent from this morning again after the computer was turned off for the night. As you can see, this problem persists even overnight, with a few sources being able to connect even though Comodo has not been instructed to allow Utorrent access to the internet, and even if you explicitly bock it from doing so:


http://s29.postimg.org/sjfb4eu5f/Clipboard01.jpg

Programacansón, I have not heard this issue reported before. Also, as others have not responded saying that they are experiencing the same problem, it does appear to be due to something particular about your comptuer. Thus, if you are not able to figure out something which is causing this the only way the devs can have enough information to replicate this is if you edit your first post to be in the required format. This format can be found here.

Hopefully this can be solved, by one of the possible issues pointed out by mouse1, but if it cannot then the only way to resolve this would be to make a formatted bug report.

If you have any questions please feel free to ask.

Thanks.

Well, I uninstalled Comodo using Revo Uninstaller and installed it again. The problem apparently has gone away.

I am never updating Comodo again though. It breaks the program and just brings heaps of trouble.

Regards.

I’m very happy to hear that reinstalling was able to solve this issue, although of course I am sad to hear that something apparently went wrong during the upgrade.

Regardless, as this issue is now fixed I will move this bug report to Resolved.

If the issue happens again please respond to this bug report. I can then move it back to the main bug reporting board for processing.

Thanks.

Hello again.

This is my last reply as I cannot divert any more time from my studies to this. I have observed again this issue even after the fresh install. This is with almost certainty a problem with the program itself, not any specific conditions pertaining to myself. I have already provided all the information that I can give, now it is up to you to give it its due attention.

Regards.

I’m sorry to hear that. However, as this does not seem to be occurring on others computers there is nobody else who can do the bug report for you. If, in the future, you are able to edit your first post so it is in the required format I can forward this to the devs, or help you complete the format.

Thank you.

I did some testing and found that the Custom policy does not filter outgoing traffic. It only filters incoming traffic.

To see the effect reboot computer. Give one of your browsers the Custom policy. Fire up the browser and it will connect to the web without a squeak from CIS. To see Custom policy alert for incoming traffic. Reboot computer give a p2p program the Custom policy and run it. You will be alerted about incoming traffic.

I did a clean installation in the process. This is a serious bug. I will report later.