No UAC popup when removing firewall / AV from CIS [Issue Report]

The bug/issue
1. What you did: Open start menu. Click All Programs. Click COMODO and open Add and Remove components.
Click Next and select Change. Now you can remove components from CIS but doing so doesn’t require administrator privileges. So now any user with standard account can remove firewall/AV from CIS.
2. What actually happened or you actually saw: There was no UAC popup.
3. What you expected to happen or see: I expected to see UAC popup. Now even user with standard account can remove components of CIS
4. How you tried to fix it & what happened: -
5. If its an application compatibility problem have you tried the application fixes here?: -
6. Details & exact version of any application (execpt CIS) involved with download link: -
7. Whether you can make the problem happen again, and if so exact steps to make it happen:

  1. Use Win 7 / Vista and make sure UAC is enabled.
  2. Install CIS or Comodo AV / Firewall
  3. Make a standard account and log in.
  4. Open Add and Remove components. Notice there is no UAC popup.
  5. Click Next and select Change. If you have installed eg. Firewall, select to add AV and remove the firewall.
  6. Click Next again and Change.
  7. Just wait until components are changed and reboot.
  8. Firewall is now removed and AV is installed.

8. Any other information (eg your guess regarding the cause, with reasons): -

Files appended. (Please zip unless screenshots).
1. Screenshots illustrating the bug: -
2. Screenshots of related CIS event logs and the Defense+ Active Processes List: -
3. A CIS config report or file. Not needed
4. Crash or freeze dump file: -
5. Screenshot of More~About page. Can be used instead of typed product and AV database version. Not needed

Your set-up
1. CIS version, AV database version & configuration used: Version 5.5…1383. Configuration doesn’t matter.
2. a) Have you updated (without uninstall) from CIS 3 or 4: Clean install
b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
3. a) Have you imported a config from a previous version of CIS: No
b) if so, have U tried a standard config (without losing settings - if not please do)?:
4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
5. Defense+, Sandbox, Firewall & AV security levels: D+=Safe , Sandbox=On , Firewall =Sage , AV = Stateful
6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate x64 SP1, UAC max.
7. Other security and utility software installed: None
8. Virtual machine used (Please do NOT use Virtual box): No

Thank you for your Issue report.

Moved to verified.

Thank you