No tray icon [Resolved]


been having a problem with the program closing after around 30 minutes. The icon disappears from the tray bar and only the BOcore.exe remains in Process Explorer. I’ve uninstalled and reinstalled but the same thing happens.

Nothing is reported in the event viewer.

Running XP Home, NOD32 and Comodo Firewall. No other real time security apps.

Just a question, but did you install under Admin/Owner?



Was Nod32 running (active) when you installed CBO?


Yeah, it was.

When you install security programs you should allways disable all your programs that protects your computer.

or else the program you install will maybe not be correct installed.
(you should do the same when you uninstall programs). or else it might not be uninstalled correct.

And its a good idea to unplug your internet kabel before you disable the programs, or else your computer is defenseless.
(Less then 5 min. without anything that protects your computer while the internet kabel is plugged, is enough to get a virus.)

Ummmmm…even behind a router? (Just checking)



Tried doing that, switched off NOD and Comodo firewall, installed BOclean, re-booted and switched NOD and comodo firewall back on but BOclean still closes down.

@Mike_P-no, I’m not behind a router.

Does BOclean create an error log file somewhere?

Will you capture a screenshot of your configuration screen for CBO, and attach to your post under Additional Options?



OK, here ya go…

[attachment deleted by admin]

Don’t know what I’ve been thinking about, JolietJake, and I apologize.

BOCore is the Service; it runs with Windows, independent of the user. Our side of it is BOC423, which you’ll see close out of Process Explorer when you select “Shut Down BOClean” from its menu.

This is similar to Comodo FW, which has a core Service that is the “guts” of the FW and runs independent of the user, from boot.


Yeah the core remains active but the BOC423 closes by itself and the icon disappears after 30 minutes or so. Are you saying I’m still protected despite the BOC423 closing?

As I understand it, it should be; just like the firewall, BOCore is the actual “core” of the application. Not sure how BOC423 fits into it. Obviously if it’s closed, the user doesn’t have interaction.

The question obviously is, why is BOC423.exe terminating? If you’re not closing it, why’s it closing?

When it does close, what happens if you try to re-run it? Do you get any error message?

Also, you can check if you’re still protected pretty simply. GRC has a leaktest for firewalls; this test “resembles” a trojan, and will be detected by CBO. You can download and try to run the test (once BOC423.exe closes out) and see what happens.


The icon will be there and if I check it by hovering my mouse over it, it disappears. I’ll try that suggestion about the leaktest thing.

Once the BOC423 shuts down all I have to do is relaunch it and it appears again.

Someone else is reporting the icon disappearing from systray, but they still have both BOCore and BOC423 running. Which is odd, too, but a bit different.

I’m interested to see how the GRC test does with your scenario.


Tried the leak test and the only response I got was from Comodo firewall.

I restarted BOC423, retried the leaktest and BOclean spotted it, stopped it and asked if I wanted to delete it. I clicked yes and it was deleted however I couldn’t access the net immediately after with either Firefox or IE. I had to sign out of AOL and sign back in before I could access the net.

A minute or two later BOC423 shut down again.

Okay, so whether the core is running or not, CBO is unresponsive when the user end is shut down. I’d file a ticket with Support on it. Provide them a link to this thread.

And be sure to keep us updated on the progress of it.


Cheers for trying to help out Little Mac, submitted a ticket and I’ll keep this thread upated.

I’m gathering there are a few issues with 4.23 that didn’t exist with 4.22; probably because of Vista changes (my guess), and lack of real-world testing. Computer labs are great, but user systems can really stress software… ;D


I don’t know why but when i open Boclean it works fine.

I leave it on for a while and then i go to click it again and it disappears?

i have to go again to start > programs > Comodo > Boclean

When it disappears i checked the task manager and it has BOCore.exe on? does that mean that is normal?