No (or fewer) connections in firewall since WIN10 Anniversary update


I did the WIN10 Anniversary update yesterday and since then I’ve noticed that Comodo Internet Security’s firewall is unable to detect most of the connections my PC is making. Until yesterday all connections (like browsers, updaters, NAS-backups…) appeared in the firewall. Also the bandwith was being displayed on the CIS logo (green and yellow arrows); I haven’t changed any setting to CIS in the last few months, all I’ve done is installed the WIN10 update. Is there some conflict going on between CIS and the newest WIN10 or do I have to look elsewhere?

I have exactly the same problem after updating to the latest version of WIN10. CIS does not see any network connections and the firewall does not block anything at all. I have been using Comodo since its early days and it seems we now have to look elsewhere.

Hey Geocom,

I’ve been tinkering around with my PC and the probleem seems to be solved. The thing that did the trick for me was to go to “This PC” > right click your C-drive > propperties > disk cleanup > Clear systemfiles (the rectangle which requires admin-elevation), and clean all of the files it found.

WARNING: this will kill the option to do a rollback as it removes the windows.old (hidden folder) from your C-drive.

Then I simply rebooted the PC and all was well. Make sure to select reboot and not shutdown as this is not the same since WIN8.

Good Luck.

Many thanks, Freddy. I may give your suggestion a try, although I’m always somewhat reluctant to tinker with Windows system files. Comodo appear to be offering no solutions to the problems that have appeared since the WIN10 Anniversary update. It cannot be Microsoft’s fault that CIS does not function since the update.

I also experienced the same problem today.

I was holding off on the Anniversary Update until Comodo releases a new CIS version with properly signed drivers, but Windows went ahead and rebooted my PC last night and I have now ended up with the v1607 Windows.

When I first logged in after the update was completed, I received a notification from my display driver’s utility that there’s a new version available. I had previously blocked that utility in CIS firewall, which I run in “Custom Ruleset” mode, so I was suspicious and started investigating. I realised that

  • I received no firewall prompts,
  • all apps were able to bypass the firewall, no matter if a rule was set for them or not,
  • the View Connections window in CIS only showed a few UDP connections by the “System” task

I performed a diagnostic using CIS Help Menu → Support → Diagnostics, and CIS reported that everything was fine! It obviously wasn’t, as my firewall was not functioning properly.

I then restarted my PC and upon logging in, I immediately saw a firewall prompt. All my rules started working again, and the View Connections window now showed all applications with active connections.

So, in summary, CIS Firewall didn’t work during my first session after the Anniversary Update was installed, but a restart somehow cured it and restored firewall functionality. Maybe it was not the Disk Cleanup but the reboot that fixed the problem for “freddy P.” as well.

Many, many thanks. I had rebooted several times without any success, but it seems that the magic trick is to run the diagnostics. Although CIS reported no problems, the firewall came back to life after that.

Now that’s weird :slight_smile: And I had thought that CIS just needed an extra reboot to pull itself together. I’d never have expected Diagnostics to make a fix without detecting any problems.

Same issue here, after upgrading to the Windows 10 Anniversary Update. No download/upload indicator arrows on Comodo and no network connectivity registering in the program.

Did a Diagnostics from within COMODO, showed all was well.
Restarted laptop and it started working as normal.

Not sure if a restart was all that was needed or the diagnostics did it, but it works now.