No longer possible to execute programs (XP SP2 Home, X32, 3.0.14.276)

Background:

  1. I had disabled D+. Everything ran fine.
  2. Another family member enabled it (Clean PC Mode) by right-clicking on the tray icon. It still ran fine.
  3. He didn’t log out but closed his desktop and went to the “welcome screen”, and later “logged in” (not really logged in, but you know what I mean) again. Now the problems began.

Problem:

  1. No tray icons left.
  2. No cfp.exe running.
  3. Admin rights seemed to be gone (despite that the Windows account had admin rights).
  4. Not possible to execute a single program (almost), except for explorer.exe, and from there I could open images with Windows Picture and Fax Viewer - but not open them e.g. with a picture-program like Picasa. I could also launch Task Manager but not by right-clicking at the task bar.
  5. Not possible to uninstall CFP 3 since no program could be executed.

Solution:
I started in safe mode, and from there I could uninstall CFP 3.

I found a post that seems to describe the same problem, but in an earlier version of CFP (beta).

/LA

Edit: not that it matters, but this wasn’t on my own computer but the family’s, on my own system (which is identical except that I have Pro, not Home) CFP 3 works perfect.

Following up this old report:

Does anyone recognize this bug, and know if it’s been fixed? I’ve looked in every change log since the actual version, but haven’t really spotted anything that seems to address this problem.

This bug is still the only reason that keeps me from really recommending CFP 3 to everyone I know - if the bug is still around, it makes some computers impossible to use.

It’s a pity I don’t have the possibility to test it immediately, since it’s not my computer and I’m very careful with others’ computers. :wink:

Thank you,
LA

Hello,

Sorry for my poor english.

The bug is still here, I’ve just subscribed to this forum fro the exact same issue…
Comodo was installed since a week or so (XP SP2 Family, Avira antivir).
The last thing that I’ve done is to launch a new application (mesnews, french news reader), comodo asked me what to do and I decided (for the first time I think) to use it as isolated application.
The application didn’t start, I tried to reboot but was not allowed to so I pressed power on which shut done normaly the computer.
Then restarted, no tray icons left, no way to launch any program (rights have vanished).

My childrens are also using (Firefox, openoffice, no games) the PC so perhaps they have allowed, checked things that I’m unaware of.
At this time, my computer is “locked”. I cannot perform an XP restore as it is an OEM release that first format the hard drive and then reinstall all XP…

So you are using the latest 3.0.24 build?

Josh

Doesn’t sound like a Comodo problem sounds like user error. You can boot up in safe mode and try doing a System Restore back to before you installed Comodo. You can also make changes to Comodo in safe mode to see what you blocked.

I don’t know I’ve downloaded it a week agao.

David

Hi David,

Are you able to access the menu,if so lets find out what is blocked and try to unblock it.
Can you remember anything about the alert?

Matty

Hello,

Seems to me that it is a Comodo issue, perhaps not a bug, perhaps a GUI issue missleading the user, I don’t know…
The fact is that it is the first FW or even software with which I get in such situation.
I’ll try to boot in Safe mode (I can do it) and perform an uninstall of comodo.

look http://www.lockergnome.com/blade/2006/12/23/comodo-firewall-problems-after-two-weeks-of-use/#comment-148863
Comment posted on the 28th of march is the exact same issue than the one that I’have (no permission despite I’m the only user), april 15th again, april 21th again, may 21th again… These are not old comments, they only have a few months for the olders.

Again, it is perhaps not a bug, but I’m not the only one experiencing this issue.

Thanks,

David
PS: if the unisntall succeed I’ll reinstall it again :slight_smile: do give it a second try or at least check what is putting XP in such a state.

Go to Miscellaneous/About. You need to read your alerts and apply the appropriate rules. There are firewall pop ups and D+ pop ups.

Hello Matty,

I can boot in safe mode and have a standard safe mode access (tried this morning).
I’m not in front of the computer right now (at work) and cannot access it (Logmein access is disable due to the problem).
I can also boot from an other XP on the same computer if needed.

Just let me know if you want me to save some log/config/??? files before trying to perform an uninstall.

David

Hello,

Is there a risk of beeing as well locked if I launch Comodo in safe mode as in std mode I’ve access to nothing ?.
The last rule that I’ve applied whaty to enable Mesnews (MesNews, Newsreader (home)) access as isolated application and then all started to be locked.
I must admit that I’ve not spent a lot of time reading documentation and that is probably a part of the issue :).

That’s why I want to give it a second chance taking time, this time, to do things correctly but before I need to get my computer back.

David

Hi David,

Maybe the D+ logs,but in this case i doubt they would be of much use!
One thing i suggest is if you get an alert for anything,unless you are pretty sure what it is,don`t tick “Remember my Answer” that way the response given should only last for that session.

Hope you get it sorted,

Matty

ps While in “Safe Mode” have a look at Defence+/Advanced/Computer Security Policy to see if there is anything which is labelled “Isolated Application”.Also look at the access rights of explorer.exe/…(highlight/edit/modify) to see if you see anything in blocked applications.

Some news.

Booted in standard mode, no access to nothing.
Ctrl-alt-del to launch the task manager.
In the task manager, Menu File run (don’t know the exact english translation) : “C:\Program Files\COMODO\Firewall\cfp.exe”

Comodo is comming up.
Disable Defense + → computer back online.

As advised, defense+/advanced/ComputerSec policy/ and bingo explorer was set as isolated application.

So, no need to uninstall, no need to re-install windows, ne need to boot in safe mode, just launch comodo from the task manager.

thanks to all for you help :).

I keep comodo and start asap to read the doc :).

David

Hi David,

Isolated application = Block all

So, Remove the explorer.exe from computer security policy and set it as Custom policy…

If you don’t have the explorer.exe in the comodo’s safe list… Go to Defense+ → Common tasks → My Own Safe files->Add-> Running process->explorer.exe and click apply

Regards,
Vicky