I have my two sons pc’s connected to mine through an ethernet card. I have my firewall configured but something is wrong becuase my boys cannot get on the interenet. They are on the network and can accsess each other without a problem it is just the net. What can I try?

When you say you have the “firewall configured” what do you mean? Have you defined a Zone to encompass all three computers, and set that Zone as a Trusted Network?

Can you post a screenshot of your Network Monitor rules (taken at full-screen)?


Yes that is what I meant by configured.The ethernet is under truted network the ip number is and I noticed one of my boys numbers was lower than this, could this be why?

That could certainly do it; the Activity Logs in CFP would show what is being blocked, IP specific.

That being the case, you could do one of two things (don’t do anything yet; just keep this in mind):

  1. Manually configure (on each computer, in Windows) the IP address to be a static IP, and assign it within a specific range. This is actually the “preferred” method, and would allow you to have (for instance, with three PCs):,,, which is a nice compact network, and easily defined within CFP.

  2. Set up different Zones within CFP, for each the IP of each “client” computer.

Did you have this setup prior to installing CFP, and if so, was it working then?

Does it work if you set CFP’s Security Level to Allow All?

What entries are there in the Activity Logs when each computer tries to connect to the internet? Will you select an entry, right-click and choose “Export to HTML”. Save the file, reopen, copy/paste the text into your post (you can then edit out IP addresses, names, etc that you don’t want to post; just leave enough of the IP addresses to show range matches where needed).

Will you capture a screenshot of your current Network Monitor (taken at full-screen, please), and attach it to your post under Additional Options (as an image file, such as a jpeg)?



Yes they work when I have it on allow all, could you please tell me how to do the ip address . I had it all working fine for about two weeks and then they couldn’t connect? I have just turned theirs on and they are now both working.This is what happens sometimes they work and other times they are blocked. I just tried to get a log of last night when it was blocking but can only get logs from 10pm last night and it was before this. I do think it is to do with the ip address so if I static them this should work. Can you talk me through what to do when they are static?
Here is a network screen.

[attachment deleted by admin]

G’day Mr.Duck,

These instructions are geared towards a LAN that is using a router to share its internet connection. If you are using Windows Internet Connection Sharing, I can’t guarantee that these steps will still work.

If anyone else out there knows more about ICS and can confirm these steps or provide working ones, please jump in.

Having said that …

  1. On one of your sons PCs, do a right click on the “My Network Places” icon and select PROPERTIES.
  2. This will open the Network Connections window which should have an icon for your LAN connection.
  3. Do a right click on this connection and again select PROPERTIES.
  4. Under the heading “This connection uses the following items”, scroll down until you can see "Internet Protocol (TCP/IP).
  5. Double click this.
  6. In the TCP/IP properties window, select “Use the following IP address”.
  7. For IP address, enter (I’ve only suggested 50 as its a very different address to the one I’m assuming is on your main PC).
  8. For subnet mask, accept the default of
  9. For Default Gateway, enter the IP address of your router (or, if you are using ICS, enter the IP address of the PC that connects to the internet - I think that’s how ICs handles it).
  10. Select “Use the following DNS server addresses”.
  11. Enter the IP addresses of your ISPs DNS servers.
  12. Click OK.
  13. Repeat these steps on the other PC, substituting for
  14. Back on the main PC, delete the rules you previously created for the LAN zone.
  15. Define a new zone with a start address of and an end address of
  16. Set this newly created zone as trusted.

Good Lord willing and the creeks don’t rise, all should be well after a reboot on all three PCs.

Hope all this helps,
Ewen :slight_smile:

O.k. I gotcha. :SMLR but can you tell me why the ip changes and goes out of range for my firewall settings? Under tcp/ip it says get ip address automatically and since boot up this morning they have both been working because the ip numbers are now in range again, what makes them change?

If you leave the setting to get an IP address automatically (which is the default), instead of making it a static IP address as Ewen explained, the following may occur:

With ICS, if a client computer is unable to connect to the internet/host computer (for any reason) in the necessary timeframe for the necessary connectivity updates to occur, it will typically assign a default IP of 169.x.x.x. This is a sort of “fake” IP which indicates a lack of connection to the shared host computer.

If this is the address you’re seeing, that’s probably what happens. If it’s not, then I’m not sure exactly why it wouldn’t be within your defined range.


Thanx. Everything seems to be alright at the moment so I won’t fiddle with it. When it happens agian I will set it at static. I don’t like to mess too much cause I don’t really know what I’m doing I just take advice and hope it works (which it usually does cause everyones great here )