No internet traffic after installing Comodo

This evening I decided to change my firewall from Sygate to Comodo. I installed the latest version and proceeded with the install (I had my internet off until the installation was completed).

During the install a message appeared saying that I was about to join a new local area network and that I should give it a name (I chose the one offered) and whether I wanted Comodo to automatically detect new networks (I chose ‘don’t’). I was a bit bothered by what these messages were saying but things proceeded and the program was fully installed.

I restarted the computer and then turned my router on and after a minute or two and clicked on my browser. It wouldn’t open, despite the fact that my network icon indicated a strong connection to the internet. I tried to open Outlook Express and it failed to do so too.

Would the fact that I turned the internet off before the installation have anything to do with the problem? I restarted the computer again but still couldn’t connect my browser or email client to the internet.

Finally I restored the computer to the restore point made before the installation of Comodo. Now I have Sygate back and all is well. I’d love to change to Comodo but wouldn’t want to go through the above again.

Would anyone have any idea what happened here? ???


yup leave your internet on, comodo installer checks your system against the cloud when installing to set itself up.

while installation you can see a “page” in the installer which tells you about comodo dns. there you have to “opt out” from “using comodo dns servers” by clicking “i dont want to use them”.

the router settings cant be changed by a firewall, because (what i hope) you are having a unique self made password for the router. how could there be changed something?

what i can imagine what happened: while you maybe had set your pc to receive his ip from the router per dhcp, there was no ip set. in combination there was no dns server set, because your router manages that.
as comodo tried to set the DNS ip, it may have set the connection settings of your PC to “use this ip”. as i see, you cant use a specific dns without having enabled a specific ip to connect to the router also. this ip was just missing.

if you want to use comodo dns (i naturally dont use it), you only need to tell your pc the specific ip which it needs to connect to the router.
OR just opt out from using the dns servers of comodo while installation.

I re-installed Comodo, having disabled my Sygate firewall beforehand (and preventing it from starting anew at startup). Towards the end of the installation I got a popup from Comodo letting me know that I was about to join a new network and that I should give it a name (I kept the one that was there already). I also ticked ‘Don’t automatically detect new networks’ and then ‘OK’. However, when I restarted my computer I still couldn’t browse the internet or read my emails, even though my internet connection was working fine. I had to do a pre-Comodo restore once again.

So, what should I have entered into those two boxes (You are about to join a new network …give it a name, and Do or Don’t automatically detect new networks)? ???


By the way, I kept my internet on during the reinstall and chose ‘Firewall Only’ when asked. :slight_smile:


This should have worked, If you receive that alert and just “Allow” it then nothing happens, It get’s added to the “Network Zones” but won’t be used, unless you check “Step 2 - Decide if you want to trust the other PCs in this network” Then it will be added to the Network Security policy.

It is important to know “What” network it found. If it alerts for 169.254 then there is something wrong with your DHCP traffic, the client (PC) is unable to receive an IP from the DHCP Server (Router?) in this case.

You can verify your current IP by opening a command-box and type “ipconfig /all” without the “” please copy this data to a text file and save it for later comparison to the version when CIS is installed.

It wasn’t one of the usual alert which I’m referring to above. This was part of the configuration process during installation. It told me that I was (a) about to join a new network and that I should give it a name (I kept the one offered); (b) It asked me to choose to automatically detect new networks or not (I chose ‘not’- should I have chosen ‘yes’?). When I clicked ‘ok’ and restarted my computer I couldn’t use the internet even though I was definitely connected according to my taskbar. The only way to get things moving again was to restore to the pre-Comodo restore point.

I know, that was exactly what I was talking about.

It should not matter if you chose “Detect automatic” this part should not block your Internet traffic.
Please follow my other post and check the “ipconfig” stuff etc…

Ok. I got the ipconfig/all details and wrote them down.

I then clicked on the exe for installing Comodo and was informed when attempting it that the data was invalid. I then went into the Comodo site and downloaded another copy and tried to install that. It proceeded so far and then, once again, said ‘invalid data’.

There was a Comodo icon on my desktop, however, so I clicked on that. Everything opened up as if it was installed, but it never got past initializing and eventually said that there were errors. There was a Comodo folder in ‘All Programs’ but nothing in add/install so I couldn’t uninstall what was now in my program files (do I simply delete the Comodo folder with its 47.1mb content?)

By the way, I couldn’t connect my browser or Outlook Express once again. I checked my ipconfig/all settings and compared them with the data mentioned earlier and nothing had changed. I again used system restore and returned to my former working system state - and Sygate.

I think that I may have exhausted my patience with this matter, but thank you all for your assistance.

Sounds to me there are some conflicting issues here, maybe left-overs from previous software causing install issues…

Did you try to clean the browser cache before downloading again?
Did you save on a local disk or on a network drive? CIS won’t install from a network share.

I can imagine your patience is running out btw…
If you make an other run try the following also in a command-box;



IP from default gateway can be found with the ipconfig command.
This will tell you if you have a connection to

  1. IP based google host
  2. DNS based google host
  3. IP based connection to your local router

Good news …and a lesson for anyone out there installing a new firewall!

It appears that although I had disabled my former firewall (Sygate) before installing Comodo, that because I didn’t uninstall it entirely it was causing problems with the new install. After uninstalling Sygate I now had no problems in installing the new firewall. Problem solved!

Many thanks for your patience, Ronny and you other guys. ;D

Can you please post the Sygate details (version download url etc), I’ll contact dev’s to let them build in detection for this, normally CIS should warn you before proceeding that FW x has been detected and needs to be uninstalled before you can continue…

Good to hear we have an other user on board :wink:

It was Sygate Personal Firewall 5.6. However, this firewall was purchased by Symantec (Norton) in 2005 and was immediately dropped by them. Therefore there’s no more support for the program - and nobody to contact. >:(

I found it here; Download Sygate Personal Firewall 5.6.2808.0 for Windows -

I’ll notify CIS dev’s if they can add this to detection, so CIS will complain if Sygate is installed

another note: people please make sure the software you uninstalled is truly uninstalled before you go complaining to the makers of the new software you are trying to install if it not working right. This happens more then you want to know.

It might be worth highlighting this in the Install / Setup / Configuration Help - CIS /FAQ section. :wink:

I also have had similar problems installing Comodo as the OP of this older thread.

I will try completely uninstalling Sygate before attempting to install CIS again.


I’m having the same problem except that I’m installing Commodo on my new notebook so there’s no previous firewall.

After Commodo has been installed, I’ve internet access through Wi Fi but not through my mobile broadband.

I’m wondering if it’s some settings/address that I need to add in the Network Zones.