No Internet Connection after uninstallation

Here is my story (gets a bit lengthy)…

I have used Comodo firewall 2.x since about a year ago on my old machine, which ran windows XP and was a really great product. Now I have gotten a new computer, which as of now is about 8 months old and runs, and it dual boots both Windows (vista home premium) and Linux (ubuntu). Recently, about a few months ago, I’ve missed having the protection of the firewall and decided to install the newest version on my machine. When I installed the new version on my new machine, I picked the wrong setting and it installed just fine (it was a setting I didn’t need) so I uninstalled it and rebooted, reinstalling comdo again and picking the right setting (lol) worked fine until it attempted to download an update, and after I exited the control panel/application and rebooted again some days later, it absolutely refused to start. I would run it as administrator, and try all I can to get it run, but it just wouldn’t come up. I got no errors or anything, but it absolutely refused to start. So for about month I gave up on it, and went about my business when all of a sudden I booted up my computer and Mozilla firefox refused to connect to the internet in anyway. Internet explorer can still connect. So I attempted to uninstall comodo firewall and it wouldn’t so I ended up using the stand alone uninstaller, which worked. I followed the instructions on how to uninstall the firewall, which to my surprise, worked. I booted up my machine again and absolutely no connection to the internet. Internet explorer wouldn’t connect and neither would firefox or any of my applications. So, from then I ended up doing a system restore to the point before I uninstalled comodo, and bam, I have internet, but only Internet explorer will connect to the internet. mozilla firefox won’t. I repeated this several times in a span of a few weeks, it has happened again and again which confirms my suspicions that comodo is the problem.

So now, as I ask for help, several more applications that could access the internet before the uninstallation of comodo, cannot access the internet. I run a local server (WAMP) which still works. But Avast cannot update anymore, so I have only resorted to downloading files that I absolutely trust. Steam, which I play majority of my games through, cannot connect to the internet, so most of my online games cannot connect, and therefore I cannot play. The only game which doesnt run through steam is Call of Duty 4. All of my applications that have the potential or must connect to the web cannot connect. These failings have only happened recently, in the last few days and weeks. Currently, the only applications that can connect are: Call of Duty 4, Internet Explorer, and my WAMP localhost server when comodo is installed. Keep in mind that I still cannot access the application in anyway and the only way to uninstall it is to use the stand alone.

Help, please, I really want my internet freedom back. :frowning:

Try Revo unistaller in advanced mode. Make sure to carefully read the instructions.