No Internet access after recent Firewall update

The bug/issue

  1. What you did: Upgraded to 5.4.189068.1354
  2. What actually happened or you actually saw: No Internet access after upgrade and reboot
  3. What you expected to happen or see: Internet access
  4. How you tried to fix it & what happened: Tried setting Firewal to Training mode. Did not help. At the advice of someone on the user forum, I tried disabling ARP Protection, which DID solve the problem. Re-enabling ARP cache protection breaks access again.
  5. If its an application compatibility problem have you tried the application fixes here?: N/A
  6. Details & exact version of any application (execpt CIS) involved with download link: Chrome Browser
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Enabling ARP Cache protection breaks Internet access
  8. Any other information (eg your guess regarding the cause, with reasons):

Your set-up

  1. CIS version, AV database version & configuration used:5.4.189068.1354 (just Firewall, no A/V)
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV = Tried several different levels for Defense+ and Firewall. Only disabling the Firewall re-enabled Internet access (I later learned that disabling ARP Cache protection solved the problem)
  6. OS version, service pack, number of bits, UAC setting, & account type: XP SP3
  7. Other security and utility software installed: Malwarebytes installed but not running resident protection
  8. Virtual machine used (Please do NOT use Virtual box):

Egemen and The Developement Team is now aware of the issue; will be fixed in the next update (soon)

Please See Here

Thank you for taking your time to fill out a bug report

Will Move To Verified