No Firewall Events Logged [MERGED TOPIC]

No writing any Loggin even if is everything repair tugging from version 3.016.295
I can’t any find why to the up - dating everything functioned well. :frowning:

same problem

Previously, my Firewall Events list contained nothing but “Windows operating system blocked”. I installed 3.0.17.304 two days ago, and ever since there have been no items to show in Firewall Events. The install was problematic and probably did not import previous settings. Today, AVG Anti-Spyware found Backdoor.agent.duj. This got onto my system before 3.0.17.304, so Comodo might have considered it safe. The Comodo scan did not find it. Is Firewall Events working properly?

The Firewall Events list is now showing “Windows operating system blocked” after I unchecked “this computer is an internet connection gateway” and and set the firewall security level to custom policy mode.
Question: Why would Comodo consider my home PC to be an internet connection gateway?

Had this problem when CFPv3 first came out.

It’s not that firewall events are not being checked, it’s just the setting that logs them.

The default setting on installation is LOW.

Just go to Firewall/Advanced/BehavouralSettings/AlertSettings and change Low to Medium and you will see all the familiar alerts you used to see with the previous versions.

Someone tipped me off about this a while ago when I was dubious as to whether the Firewall was actually working or not.

Hope that helps,

Mike.

P.S. I think the Comodo programmers are in a no win situation with regard to the logging; if they set the default to Medium they get a lot of complaints that the log is filling up with hundreds of entries every day; and if they set the default to Low then people think the Firewall is not working.

That someone might be me wink

Anyways, if medium doesn’t help then you can perhaps trying setting the sensitivity to Very high and see what comes from that.

3.0.17.304.

Always no enters to the log such is non-permissible isn’t non - check what is off limits. (:AGY) (:AGY) (:AGY)

XP home oem

No too sure what your problem is but this thread may explain some of it…

https://forums.comodo.com/help_for_v3/no_firewall_events_since_3017304_found_trojan-t19761.0.html

Hope that helps,

Mike.

A few days ago I upgraded CFP to version 3.0.17.304. Now I find firewall events are no longer logged. I have had zero logging since the update. Logging is not disabled in the settings either.

As a test I ran the shieldsup port scan at GRC.com with my router in DMZ mode using the IP address of the pc in question. I found the firewall is running and passes the test though no events are logged. Also the summary tab shows no intrusion attempts.

I uninstalled CFP without problems,rebooted then cleaned up leftover folders, reg keys etc. then and installed CFP 3.0.17.304 clean. Same problem, no logging.

I then uninstalled CFP 3.0.17.304 rebooted, used the cleanup above, and installed CFP 3.0.15.277 and logging works just fine.

Does anyone else have this problem?

I’m running XP pro sp2 32 bit.

Hi wonderwrench

I have found that CFP v-17 does not log unless you have the log check box checked in your firewall, network security policy application rules, right click the rule and edit.

John

Got the same problem. No logging of intrusion attempts, and unfortunately got zapped with the Brontok on the work network while the firewall was updating - major security problem there if you ask me, what is the point of having the firewall if it drops defenses while it is updating? ANyway not to hijack the thread, but I unfortunately don’t understand the sulotion to wonderwrench’s problem given by JJasper. Any possibility of explaining it to me like I’m a two year old?
Thanks
Mike

Hi, i try last version of Comodo FireWall “3.0.17.304”

the problem: It is simple. No logs in “FireWall Events”

  • no spyware,etc (PC is absolute clear)

i start on v3 with version “3.0.15.277” and there i donnt have this problem. Next update wos “3.0.16.295” but i have this version only few day, and i find always logs clear. I read on this forum this version have this problem.

Maybe is problem, i use update in this program. I have realy much problems when i try install/uninstall and this three version (only 3.0.15.277 works with logs). Version 3.0.16.295 is unstabile in try reading logs, settings in Defense+ (turn off and after that turn on “COM”). Version 3.0.17.304 is more stabile then “16.295” but, still unstabile in few case in settings (freeze).

Me one Q is important destroy all our FireWalls Rules ? when i update to new version ? Update:(when i update to new version i do clear the Rules in update client)

Hi Merax,welcome to the forums,2 Questions

1 Are you behind a router?

2 Have you ran the Stealth Ports Wizard since updating to .304?(look at your Global Rules)

Matty

I do not get it either. “I have found that CFP v-17 does not log unless you have the log check box checked in your firewall, network security policy application rules, right click the rule and edit.”
For which rule? I do not have logging disabled so all attempts should already be logging trouble is they are not.

Do you guys have the Block and Log rule as the bottom rule in Global Rules?
Since the update there was only 1 rule put there,you may need to run the Stealth Ports Wizard again.

Matty

  1. I have 2 connection
  • LAN (i share me iNET viva cabel to one other PC (with no problems))
  • WiFi (wifi to me WiFi networks (one AP (set up as repeter) and one AP (gateway with firewall)))

So, i have FireWall but HW on me first hop in trace route … but no SW or other in me PC and i think you ask me for this options :slight_smile:

  1. No, i donnt use steal ports … only block, ECHO request i think wos there (by default create Comodo)

For an answer to ‘No logs in Firwall Events’ see this thread…
https://forums.comodo.com/help_for_v3/no_firewall_events_since_3017304_found_trojan-t19761.0.htm
(It’s just the log settings that are set to LOW by default.)l

This i try this before you write the link and donnt work for me, but for surety i try it again.

So, i right now install last version (3.0.17.304, always to no default directory) and try :
Firewall/Advanced/BehavouralSettings/AlertSettings
change to Medium or Very High

Situation :

  • Settings of default installation FW (Train with Safe Mode) and Defense+ (Clean PC Mode)
  • i change settings of FW to “Custom Policy Mode”
  • so, settings of FW (Custom Policy Mode) and Defense+ (Clean PC Mode)
  • i change Firewall/Advanced/BehavouralSettings/AlertSettings to Very High
  • FW is in Custom Policy mode: event for FW and i block this event (app is blocked, true)
  • in Logs, no any event
  • i change Firewall/Advanced/BehavouralSettings/AlertSettings to Medium
  • again one event for FW and i block this event (app is blocked, true)
  • in Logs viewer freeze (comodo works on backgroud, but GUI donnt response)
  • Restart Windows 32b XP SP2
  • so first warning post is “XPCOM Event Reciver” “donnt response” => Kill
  • next warning post is “Comodo Firewall Pro” “donnt response” => Kill

after restart, in only Firewall/Advanced/BehavouralSettings/AlertSettings Medium no crash, but i donnt try again change settings. I try same event, no logs again.

So no works to me, no logs again and crash with Defense+ (where is setup COM events)

Update : Try Defense+ Logs :

Situation :

  • Settings of FW (Custom Policy Mode) and Defense+ (Clean PC Mode)
  • i change Defense+ settings to Train with Safe Mode (one up after Clean PC Mode)
  • i run one program and have Defense+ event, i block it (works, blocked app)
  • i open log vierer in Defense+, freeze again window “Defense+ Events” “donnt response”

Comodo still works on backgroud, but GUI donnt response.

When i look intro me Process Explorer (by Sysinternals), there is only tread CPF.exe, so i cannt kill Logs viewer (the “cfplogvw.exe”). I think i saw in settings Comodo FireWall (in older version) turn off self defend (any other program can kill CPF, is there this options in “304” ?)

Update 2 : Maybe move this topic intro bugs (i think this isnnt for help anymore)

I donnt know how, but this happened to me (before that, events works good, i donnt have exactly idea when crash) :

Situation: Comodo Firewall Pro donnt bring me FireWall event

  • Settings of FW (Custom Policy Mode) and Defense+ (Clean PC Mode)

  • detail of FW settings : Firewall/Advanced/BehavouralSettings/AlertSettings to Very High

  • detail of Defense+ settings, default : Only “COM…” is turn off

  • startup new application (run same application) - this app donnt have any FireWall rules yet.

  • the application cannt conect to internet, its blocked (i know that app try connect to internet, but no see event from Comodo (and logs no work to me))

  • so, i try create rules by self (finding the app “*.exe”)

  • when i create rules and define it, app no problems and works fine

  • so, i try again with other app , again the same, no event again from comodo

  • when i create rules and use in Comodo, tread viewer (runnigs process) i donnt SEE there the application (maybe is there problem, for me is surprise)

  • at last, i try open Logs viewer but again crash me (how i write in last post), so i go restart system. Update : After restart with the same settings of FW and Defense+ events works fine (same test like i write top).

Anyway, Comodo FireWalls Pro works fine (fnx for that). I try get away from bugs i know, because is 99% crash for comodo on me PC.

View Firewall Events i View Defense +Events No log
Even if give record Log simply isn’t entry and all is well adjusted.
I simply shan’t at all none commentary nor from blocked application.Even if require record. :‘( :’(
Such occurred from version 3.0.16.295 Version 3.015 works all right

Widows XP home cz 32 bitů s Net framework 2
System be free of virus and all other infection examinational and on new clean installation (:SAD)

I install new update “3.0.18.309”. Still same problem with Logs viewer (no any history in logs) :

  • Settings of FW (Custom Policy Mode) and Defense+ (Disabled)
  • detail of FW settings : Firewall/Advanced/BehavouralSettings/AlertSettings to Very High
  • run same app (rules is set to block this app)

No logs again, but in Summary/NetworkDefence i have “The FireWall has blocked 1 intro…” (i think i wos there mesage in last version too, but i donnt sure now)

I try in Miscellanous/Settings/Logging disable and enable FireWall Logging, but donnt help.

I wos disabled Defense+ (in last version, because crash me NetBeans 6.0 when i run debug of me project). And if i turn off Defense+, no crash in Comodo Firewall Pro (like freeze what i write here, btw i try Defense turn to Clean PC Mode in this version 3.0.18.309 and open Log viewer => Crash and freeze, like in 3.0.17.304)