No CPF icon in system tray - ?

I installed CPF 2.3.4.45 today, and it seems to be running all right. But when I re-boot the computer, there is no CPF icon in the system tray. Should there be? I have run CPF Launch Pad from the desktop and set the option to “Start Comodo Launch Pad on Windows startup”, but the check make disappears after I reboot, and there are no Comodo icons in the system tray.

What am I missing here? I believe CPF is running after a reboot as cmdagent.exe is in Task Manager. I’m running XP Pro if that makes a difference.

There should also be a CPF.EXE process that is started as a startup item, something like this… :\Comodo\Firewall\CPF.exe /background. It’s this program that creates the systray CPF icon.

Do you have something that scans and/or protects startup items?

Do you have something that scans and/or protects startup items?<<

No, I don’t think so.

Where should cpf.exe be launched from? The Startup folder? I tried creating a shortcut using :\Comodo\Firewall\CPF.exe /background (using the correct path, of course), but Windows didn’t seem to like the /background parameter.

More clues, please! :slight_smile:

You need to specify it like this…

            "C:\Comodo\Firewall\CPF.exe" /background

Note the quotes ("), this should make windows happy. But, back to the original issue… where is it?

You should be able to see it in the startup section of MSCONFIG. To create a proper startup, then you will either need a tool (which allows you to create/edit startup items) or re-install CPF (via. un-install & install).

Hi Kail,

I think what they mean is this, when you uncheck launchpad, reboot, no CPF icon appears and you in fact have to use launchpad to get CPF back which is an issue I just ran into tonight myself. It’s as if you either have both or none. I know they will be getting rid of launchpad altogether so perhaps this will fix the issue.

Cheers,

Paul

Are you sure? That CLP option was meant to knock off CLP, not the CPF icon. Wasn’t it? In addition, the above command was installed in the startup section by CPF 2.3.3.33 & 2.3.4.45… not by me.

You should be able to see it in the startup section of MSCONFIG.<<

You have good instincts! CPF.exe did not exist in msconfig. I uninstalled and reinstalled, and all is well. I now have two CPF icons in the systray upon reboot. Now I need to see if I can get rid of the superfluous Launch Pad icon. :wink:

Thanks for your help - much appreciated.

Exactly, this just started today. If I reboot, I get nothing. If I kill the launch pad, I have no option to get CPF back,no icon no .exe. This is a sudden issue I may add. I have installed nothing new or anything. I am confident it’s a minor gliche however. This HP with XP home is a real mother…in law. :wink:

Cheers,

Paul

Hi, Just right click the launchpad icon in the tray, options, uncheck start clp.

Cheers,

Paul

What Paul said should get rid of the extra Comodo Launch Pad (CLP) icon. But, if it doesn’t then don’t worry, you’ve just got the old version of CLP. Just disable it using MSCONFIG.

Kail and Paul,

After finally getting CPF installed properly so that I had CPF and CPL icons in the system tray, I tried disabling CPL by right-clicking on it and unchecking “Start Comodo Launch Pad on Windows startup”. Unfortunately, upon reboot, that caused CPF to once again not load at all. This is the same behavior that Paul has observed.

So Kail, I took your advice and disabled CLP in msconfig.

Thanks to both of you for your thorough and prompt help. This forum is first-rate.

Nancy

Oops. That doesn’t sound right. You obviously have the latest CLP & that option should have stopped CLP from starting, not CPF. Sounds like a b… sorry… feature to me.

Anyway, glad you’re sorted Nancy.

I suggest uninstalling and get the latest one w\updates\fixes and trying that.

Cheers,

Paul

I’m not sure that I understand what you mean (in the above context)… In any event, CLP seems to have an undocumented feature (aka. as a bug… there I said it) & perhaps it should be reported (if it hasn’t already been so) in the CLP forum. That’s all that I meant by my last post… other than being happy for Nancy.

Sorry Kail, read it wrong, fixed now. I thought you said sorry as an apology, so I took it wrong, MY apology. But hey, my intentions were good! :smiley:

Cheers,

Paul

Ah, I see. Well, I’m sorry for making you think that I was sorry. :wink:

PS Sorry. ;D

And I apologize for that. :smiley: :wink:

Cheers,

Paul