No amazon instant video

Amazon said that they only support adobe flash player in chrome and Firefox now. I know that CD is chrome based but I can’t play any amazon videos. Is there a workaround. I tried using the IE plugin that let’s you use silverlight in CD but it wouldn’t work either.

Hi and welcome Myteedog,
Using the following site.

  1. Select your operating system.
  2. Select FP 18 for Opera and Chromium-PPAPI.
  3. Close the browser and navigate to the recently download installer and execute.
    Current Flash version

Kind regards.

So I tried that again just to be certain and it still doesn’t work. It was working fine after I did the flash player update last week. But it isn’t working today. It says “DRM Error 3307 Sorry we are unable to stream this video. If this problem continues, contact Amazon Customer Service”. Which I did and they proceeded to tell me that only Firefox and chrome will stream. So I am at a loss for the moment.

Thank you for your assistance though.

Hi Myteedog,
I am stabbing in the dark as I do not have an Amazon account, sorry.

Have you checked to see if your Amazon instant video settings are set to use Flash?

Note: NPAPI plugins are now disabled by default, resulting in the Silverlight plug-in being disabled.
A temporary workaround is to enable NPAPI plugins is to type chrome://flags/#enable-npapi into the address bar and enter.
Select enable of the highlighted entry and relaunch the browser.

Note: The above workaround to enable NPAPI plugins is not recommended for security reasons and it will most likely be removed from version 45 and above (Estimate: September).

Kind regards.

Thank you for all the help on this. I checked my amazon settings, enabled npapi on 3 different computers now and still no video from amazon. YouTube works fine though. Works through IE and chrome v 44.0.2403.89.

You are welcome, sorry we haven’t succeeded.
I am wondering if there have been some recent changes to the licencing requirements to play this content.

No promises, but I will try to find out more by asking Staff (Edit: I have now sent a PM to Staff in regards to this issue).

Thanks for your patience on this issue.
Edit: Spelling correction.

No problem thanks for the effort if nothing else. I also tried uninstalling CD and reinstalling it and Chromodo also with no positive results.