No adapter after installation


I’ve just downloaded and installed the Comodo Firewall but when it comes up there is no adapter visible in the Adapters column and no traffic is permitted to the net. However, my machine has a builtin Broadcom NetExtreme Gigabit controller for ethernet which is working perfectly when the firewall is uninstalled. After installation, even though the adapter is not visible in Comodo, I still get the normal network icon in my systray but it never indicates any traffic. I am using Windows Xp Home SP2 - installed are Nod32 Antivirus. I’ve disabled Windows Defender. I’ve disabled a few Windows services over the years - is it possible that it requires particular services to sniff the adapters?

Any idea as this looks like a great firewall but I can’t use it and it’s hard to request feedback as I have to uninstall everytime I want to connect to the net!


Hi ajax,

Do you have Sygate firewall still installed? This may be one of the reasons if you have.

Also make sure “Security->Advanced->Secure the host while booting” and “Security->Advanced->Secure against trojan protocols” options are disabled.


Thanks for the response. I did not have Sygate Firewall installed abd I remember “Security->Advanced->Secure the host while booting” was disabled (because I tried installing with this enabled first). The second feature, “Security->Advanced->Secure against trojan protocols” , would have taken the default values since I can’t even remember seeing it. Does that default to true or false?