Nintendo Wifi [Resolved]


Can anyone help?
I’ve just installed comodo as recommended by a few people, but i’m getting the following issue when i try to use it with my nintendo wifi usb dongle:
The software seems to install fine, it recognises my DS and allows it to talk to the PC. Then when it’s doing the “connection test”, it shows three green bars for about 15-20 seconds (and the PC shows that I’m connected), then suddenly goes to red, no signal, PC says no users connected. It returns error 52003 and says it can’t find an IP address.

I’ve no idea what i can change to get this working, although i know it will work fine on windows firewall, although the lack of security from that kind of puts me off!

Please help.

When you turn the firewall to “Allow All” in the interface, does this do anything? Also what do your logs show?

Which firewall?
The windows one works ok with wifi usb thingy, the comodo one not.
I’m new to comodo though so not sure where to check settings, sorry…


First turn off the Windows Firewall (not a good idea to have 2 firwewalls running at the same time) then set Comodo to “Allow All”, can you connect to Nintendo Wifi now?

I don’t have 2 firewalls running at the same time, what i’m saying is that if i switch off comodo, i switch on windows firewall.
I’m a bit reluctant to set comodo to allow all, aren’t i basically leaving myself wide open to attacks then?

What Justin is trying to get you to do is, have Comodo Firewall running and then Set it to ALLOW ALL just for a few minutes to test if your Nintendo wifi works. If it does work with Comodo set to Allow All, then everyone will know it is Comodo that is blocking it some how and people can try to help figure out what settings you need to make it work.

You should be fine with Comodo Firewall set to allow all for just a couple of minutes while you test it.

Rather strangely, when it’s on allow all, the same thing happens as before, ie the same error, yet when i switch the comodo off completely and switch on windows firewall it works fine…curioser and curioser…

Well i mailed nintendo direct, their reply is below. What an absolute waste of time.

Dear Customer, thank you for your e-mail.

This item has been tested thorougly and works fine.

I cannot give you setup instructions for your firewall, such information should be readily available either from the company that makes the software, or in the documentation you received with it.

Kind regards,

Your Nintendo Team

do you have an application rule for “NintendoWFCReg.exe”?

If not create one. And tell it to allow everything for this program. If you already do, try deleteing it and manually creating the rule and setting it to allow everything.

I got the info from some Google searching.

Google Search on this and you will find lots of others with the same problem.

nintendo wifi 52003

or click here


Also found this on nintendo site

Tried that, gave it access to everything, it still gives the same error.

This is driving me up the wall, i’ve tried everything i can find google suggests already, and Nintendo don’t want to know, they just tell the problem is due to a 3rd party software (ie comodo PF) and tell me to contact them.


Ok, one of the suggestions is to bridge the connection. ???

Also check here

Some more ideas

Tried bridging the connections, it gives an error
“To create a network bridge you must select at least two network connections that are not being used by Internet Connection Sharing.”
The ADSL connection isn’t using internet connection sharing, and the nintendo usb one doesn’t have an option on the settings to turn that on or off.

The link you provided i’ve already worked my way through, no joy.


Ok BlueBris I am going to send you a PM, lets fix this problem once and for all.

I have the same problem, can someone help?


Unfortunately I am not sure if Blubris ever resolved his problem because he did not post anything so there is no complete solution as of yet that I know of.

What did you try so far? Have you tried the suggestions in the above posts?

I have been able to get the wifi usb connector to detect the wii system, but the firewall doesn’t allow the wii to communicate with the internet through the usb connecor.

When I set the firewall to custom, the wii doesnt communicate but on full access I get a response and the wii goes online.


I am not fully understanding your issue. Your Wifi USB Connector as I understand will enable you to connect to wireless internet, but why are you using a Wifi adapter when the Wii has a built in Wireless internet card?

It needs a wireless router to communicate with the internet, but I dont have one so im using the usb wifi connector.

Here is the official Nintendo web page that explains what you have to do to get this to work with a firewall:


Ive been trying to follow that but I dont know how to configure the firewall correctly.