Newest update crashing my Win7 64 bit

Updates were available for CIS on 01-29-10, I did the update and restarted when prompted. During the restart the system blue screens, too fast to determine what message pops up. I did the system restore and it goes back to working fine. I scratched my head for a few days. I do several windows updates and reboot with no problems. This morning I decided to try the CIS update again, I do the update, it prompts for restart and I do, the system blue screens again at the same exact point. The only way to regain stability was to do the system restore again. Needless to say, I’m hesitant to do the update any more. I looked in the system reliability logs for both dates and there is the same critical event, it says, “Description: A software patch prevented the system from starting.”

Any ideas or reports of crashes with the last update?

Is there any more information what software patch is preventing the system from starting?

Can you look and see if there is a minidump report from this crash. Read [url=http://Important: how to submit bugreports (read this if you want them fixed)[/url] on how to find the minidump file.

Not having any luck with the dmp files. The last one created was on 12/09/2009. I had a problem with Norton AV causing the crashes back then, I removed it (yes used the removal tool) and installed CIS. I’ve done a few updates with Comodo after installing it and restarted with no problems. I’m about to repeat the Windows updates, restart, then do the Comodo updates again to see if I can get a dump file to be created if it crashes again,

I looked in the system reliability logs for both dates and there is the same critical event, it says, "Description: A software patch prevented the system from starting."
Does the log tell us what software patch is interfering?

Keep us posted.

It doesn’t specify which patch is causing the problem. So far I have done the Windows 7 updates (7 at once) three times. After I reboot (after the windows updates) the system reboots fine, no problems. All three times after doing the update from CIS, the system bluescreens when the animated windows logo is about to disappear and the rotating ring appears.

Another weird thing. When I click on ‘about’ in CIS it says version 3.14.130099.587

When I click on ‘update details’ in CIS the update it wants to install is Version 3.14.130099.587 : 1 February, 2010.
This might be due to me doing the prior updates but the system blue screening and having to use the restore feature in win7.

I’m thinking of uninstalling CIS, using the removal tool, then downloading the latest version Version 3.14.130099.587 and reinstalling. Maybe the first time it crashed ■■■■■’d something.

Don’t forget to export your current configuration before doing a clean install. It will save you from having to set up your rules all over again.

I figured out the problem. It was my fault. A few months ago while looking to tweak Win7, I ran across an article that explained a tweak for faster shutdown. This tweak changed the ‘waittokill’ timer for hung apps and the system from 20,000 ms to 5,000 ms. I adjusted the “wait to kill system” timer to 30,000 ms and the “wait to kill hung app” timer to 20,000 ms. I did the update and it worked. I suspect the registry hack was shutting down the update before it was finishing.

Learn from my mistake, use caution when playing with registry tweaks.

Thank you for reporting back. Yes, errors sometimes come from places where one would not immediately expect them to arise from…