Newbie help required with ftp access being denied

My first time posting so Hi to all

I have just installed Comodo Firewall 3.8.65051.477 (well some hours ago actually) and have been busy allowing all my necessary program’s access and so on.

I must say I’m pretty impressed with Comodo so far.

My one problem at the moment if with trying to connect to FTP . I have used smartftp for years with no problem but now I get the message

“An established connection was aborted by the software in your host machine.”

I have allowed access to this programme and even added it under “define a new trusted application”.

Andy Ideas

Did you run “Stealth port wizard” by any chance ?
Can you please check to see if there is traffic blocked to your ip address ?

I think this is the Active channel failing to connect to your system from the servers sourc tcp 20.

Can you try to set the Connection type to FTP Passive or PASV ? that should fix the problem so there will be only outgoing traffic from your host the the FTP server instead of the FTP Server trying to connect to you.

Hi Ronny

Thank you for your quick reply.

No I did not run “Stealth port wizard”

As I have said I’m a complete newer here so please bare with me if I appear not to understand what you are telling me. 88)

Where do I check “if there is traffic blocked to your ip address”…….is that via Active connections. If so then none appear to be blocked.

Where would I “set the Connection type to FTP Passive or PASV”

Cheers :-TU

No problem, I’ll try to explain a bit more :wink:

If you open the GUI and go to Firewall, and click on “View firewall events” it will open the log viewer and could be showing some traffic being blocked/allowed or asked.

You can find how to change SmartFTP for Active or Passive FTP.

Feel free to ask more !


View firewall events shows nothing and is empty

View Defence plus events shows traffic

[attachment deleted by admin]

Thanks for the link. I can following instructions up to:-

“From the SmartFTP Favorites window select the Favorite of interest (check the Quick Connect folder). Right-click on the Favorite and select Properties. The Properties dialog appears”

However when next it says

“Under the FTP option select Connection. From the Connection tab under Data Connection you can change the Mode to Active Mode (PORT) or Passive Mode (PASV) for the selected Favorite”

I only get General, Sharing and Customize options. No option is given for “FTP option select Connection”.

There is by the way a PASV button on the smartftp toolbar, which has made no difference 88)

Just to make sure, if you Select Firewall Security Level “Disabled” does the FTP work then ?

No I disabled Comodo completely just to see if I could connect without any luck.

So I am contacting good auld NTL tomorrow as it appears to be a problem their end and not with Comodo.

My apologies to all for even suggesting that this was the case.

I will of course post back the results.

Can you tell me though why View firewall events shows nothing and is empty and yet View Defence plus events shows traffic ???


My name is Jacob Kilgore,
I’m one of the Moderators here at Comodo Forums
I would like to Answer your question

Firewall Events Show things that happened with the network (Denied Connections, Intrustions, etc etc)

Defense+ Events Show things that happened with the PC (Alerted Actions like Program A create Process Program B, or Events Like when you changed Defene+ Security Level to Safe Mode, Clean PC Mode)

Another Summary:
Firewall shows things that is related to the Network/Connections
Defense+ shows things that is related to everything but Network (CPU/Memory)

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

Hi Jacob

Thank you for your reply and your explanation……………that’s answered my queries for me. :-TU

I am now waiting for Virgin Media to call be back as my problem has been passed onto a supervisor 88)