New User | Allow my laptop to get access to my desktop-PC [RESOLVED]

Hallo to all,

i’m new with using comodo and i’m form germany so excus my not so good english. I allready post my issue in the german forum (click) but they said if i want more help i should post it here.
So whats my Problem, i first used Sygate Personal Firewall but know i changed my OS to XP Pro x64 and SPF no longer works. I decided to use Comodo now cause i often read that it is a good alternative but know i have to notice that Comodo is more komplex with even not more functions…

What i wanne do is allow my laptop to get access to my desktop-PC via the network. They are connect by a switch. My laptop has the IP 141.30.211.212, i thought its a good start to add it to “my network zones” so i did and then i added it to the “global rules” with the “stealth ports wizard”. I checkt to connection on my laptop via ping(.exe) and the windows networksearch for IP 141.30.211.112 (the IP of the desktop-PC), but it didn’t work. Side not: my Desktop-PC can connect to my laptop.
After a reboot i noticed an other problem, ervery time i reboot the new setted zone in “My Nework Zones” disapears. I found this topic in the forum:
https://forums.comodo.com/bug_reports/cfp_3025378_xp_sp3_zone_disappears_on_reboot_from_my_network_zones-t24435.0.html
and so i downloaded the older version of Comodo form here:
http://download.comodo.com/cfp/download/setups/CFP_Setup_3.0.24.368_XP_Vista_x32.exe
But even with the older version i still have this problem

So know im locking for help with two problems.

  1. how can i fix this problem with the disapearing zones?
    and
  2. how do i allow my laptop to get access to my desktop-PC via the network?
    So could you please help me?

Sad (sorrow for loosing SygatePFirewall)
Max

PS:
I also added a rule to the “global rules” with the single IP in source that allows in/out traffic by TCP or UDP on any port and any destination, but it also didn’t helped.
Why isn’t it as easy as in SPF where i had the “komplex Rules” that where like that:

http://img440.imageshack.us/img440/1258/sygatexz9.th.png

i would be mutch easyer if we would have a menu like that, cause if I want that IP to have acces to MY system, WHY NOT it musstn be so complicated cause its MY PROBLEM and I HAVE TO KNOW IF ITS OK, not COMODO!

PSPS: I added two pictures thes first shows the “My Network Zones” window with the missing zone, the second shows the global rules window. Where you can see the rule i added and the two added by “Stealth Ports Wizard”.

[attachment deleted by admin]

Hi kleineMax,

The vanishing network zone thing is a strange one.Anyway when you try to do it with your own rules make sure you put a rule in “Global Rules” and one in “Application Rules” under system.Sorry i can`t be of any more help.

Matty

Yeah they told me already in the German forum, but then they korrekted them self cause the Global rules are of higher priority for the inbound traffic (they said). Anyways i also set a rule for the System Appl.

http://img151.imageshack.us/img151/8774/zwischenablage02wy7.jpg

… and yeah… it still doesnt work -.-

Have a look at

https://forums.comodo.com/help_for_v3/rules_dont_seem_to_take_effect-t24852.0.html;msg177639#msg177639

This post is about how to BLOCK a particular PC on a LAN, but it is still relevant to your issue if you substitute ALLOW for BLOCK in the rules.

Prior to doing this, please remove any other manually created rules.

Ensure that the two newly created rules are moved to the top of the Global Rules list, as these rules are read top to bottom.

Hope this helps,
Ewen :slight_smile:

I set the rules like you explaied and after a reboot it worked. But my Question why doenst it work when i set one rule that allows in/out traffic from my laptop pc?

And just little qustion, it should have worked if i set the rules by using the "my network zones and the “stealth Ports Wizard”, the only problem is that the zones disapear right?

Anyway thanks ^^

PS: I said to much… it doesn’t work anymore… it only worked once, it worked with ping and also in windwos network(viewer) but know my laptop can’t ping and find my desktop-pc anylonger. o.O thats crazy i didn’t changed anything !!!

Are your PCs connecting via a DHCP serving router?

hm … good question, i dont know… but i would say no!

I’m a student and im living in a hostel that has it’s own network with connection to the internet. My two PCs are connect to a switch (in my room) and the switch has an uplink to the rest of the network, but i dont know whats comming after the uplink.
But we have fixed IPs so that shouldn’t be the problem right? And also all other neworksetting are fix and do not change (IP, Subnetmask, gateway, 1. DNS, 2. DNS)

PS: Maybe it didn’t worked bevor :smiley: maybe i just entered the worng IP on my laptop when i tried to ping my Desktop… ^^ maybe the one of the laptop. 88)

To KlineMax,

Two comments although I do not know how much it will help.

(1) You may be barking up the wrong tree if this is not a Comodo3 problem. So if nothing else, you can right click the comodo icon on your task bar and temporarily set comodo to disabled, and D+ to disable on both the desk top and the laptop. And see if the problem goes away. And if the problem does not go away, it may not be a comodo caused problem. And if does go away, then you can selectively re-enable Comodo3 and D+, run the various permutations, which will give you a clues on where your problems are.

(2) Since I think everything works as it should when just the desktop is plugged into the Hostel network, you may want to create your own subnetwork that runs through your desktop. You might have to buy an extra network interface card ( a NIC ) for your desktop and a crossover cable. Then connect the desktop as before to the hostel network, connect your extra NIC and the laptop with the crossover cable, and then set up a ICS network between the desktop and laptop. With careful shopping, those two items can be purchased at a price that will not bust your budget. Or even borrowed to make sure the concept will work.

Ok now i’ll axplain it simple for you again. (Cause you didn’t read what i wrote)

  1. I used Win XP Pro 32bit on my Desktop bevor and also Sygate Personal Firewa. Now i have XP Pro x64 on my desktop and cause SPF doesn’t work under 64bit i installed Comodo.

  2. My laptop is unchanged, so it still has XP Pro 32bit an Sygate PF#

  3. The Problem didn’t exist bevor i installed x64 and comodo, everythink worked fine with SPF

  4. I tried it bevor but didn’t mention it and now i trie it again… and yeah again i get a connection form my Laptop to my Desktop when i disable the comodo firewall (D+ is allways disabled)
    You see the source of the problem is (B)

But thanks for trieing to help me

Are there any relevant entries in the logs from when it stopped working after it had worked briefly?

To KlineMax,

I am still trying to understand your network and how it works. And equally importantly, why sharing worked with Sygate and not comodo3. But at least you have moved somewhat uphill by isolating the problem to the desktop.

But lets still play the what we know game.

  1. We know there is a hostel wide network I will designate as A. Said hostel network has internet access and distributes that, presumably through a router with its own set of rules , to the various rooms in the hostel.

  2. Then you have a desktop computer I will designate as B. B connects to Network A, I assume via a presumed patch cable from B’s ethernet port to ethernet wall jack and has a static ip of 141.30.211.112.

  3. Then there is a laptop computer I will designate as C that connects in basically the same way to network A. With the laptop having a static ip of 141.30.211.212.

But the weird thing is that there is some switch, presumably having two ports, and that switch then supposedly connects to the lone actual ethernet port in your Hostel room. And that both computers B and C connect to that same switch. And for reasons I can’t quite understand, some network sharing becomes possible through the switch for B&C when Sygate is working on B or if comodo is disabled on B.

But before I make too many presumptions, I should ask klineMax if I have it right so far?

But assuming I have it right, its my network understanding that sharing should be implemented through the larger network A. And if your two computers, B&C with two different IP’s can see each other to share, why should you not have the same ability to see and share with every computer in every room of the Hostel? And questions about the IP’s of network A and its various gateways spring to mind.

That along with the fact that comodo3 seems smart enough to reject various phony rules seem to suggest you are on the wrong course.

If your problem is not yet solved, could you try the following on your desktop?

Go to: Firewall | Common Tasks | Stealth Ports Wizard
Select : Define a new trusted network - stealth my ports to everyone else and click Next
Select the second option: I would like to define and trust a new network zone
Fill in the Starting IP: 141.30.211.212 [IP address of your laptop]
Fill in the Ending IP: 141.30.211.212 [IP address of your laptop]

Click on Finish.

Now ping both ways and check.

[ at ]panic

as i said it maybe never worked cause i think i entered a wrong IP adress on my laptop for the ping test. I think it was the one of my laptop :slight_smile:

[ at ]Osage

Alright so far but one litte thing.

I can see many other computers in the network in my Networkgroup and also I see other Networkgroups some i have access to some not.

PS: …
@cloudforest

your the man… now it seems to work, the ping test that i made was a success but lets see what is after an restart.

Just as a learning exercise, have a look at the rules created by the Stealth Wizard and compare them to the rules suggested in the beginning of this post. They should be very similar.

Glad to hear it’s worked out for you. Hope to see you around the forums.

Cheers,
Ewen :slight_smile:

cloudforest i dont know what you did with my firewall or PC maybe you hackt it and reseted my whole systemsettings. Or your are a wizzard… yeah maybe thats the point.
Anyway all works and i can exchange data between my PCs.

But even if the result counts i still wanna know why it works when i use the wizard. And not by setting the rules manuel

PS:
Ok I found out the differenc, its the Protocol. The rules bevor had TCP UDP and the rules set by the wizard have IP.

Glad to hear it’s worked out for you.

[at] cloud forest - thanks for jumping in with Occams Razor swinging - simplest solutions is generally the best. :wink:

I’ll mark this as resolved and lock the topic. If you need it re-opened, please PM one of the mods.