I have been running CIS for about 9 months now and a couple of weeks ago I updated to version 3.8.64739.471. After restarting my pc it stated that the firewall was not running properly, and I kept on getting messages which said that new updates were avaiable but after pressing to accept a message said that there were no updates. I had a look around the forum and after seeing that others were having the same problem I did a system restore and waited until the problem was sorted.

Then today I downloaded the new update 3.8.65951.477 but this has not cured the problem which still shows that my firewall is not working properly.

I have Vista 32, AVG Anti virus, Comodo BO Clean, Ad Aware Free, Malwarebytes Anti Malware.

Everything has been running fine together until the above updates.

By the way on both occasions when I downloaded the updates the files in MY PENDING FILES disappeared.

Any advice would be appricated



CIS has a known problem with Ad-Aware. The devs are working on fixing it though :wink:

The only known solution is to uninstall Ad-Aware, I’m afraid (or CIS, depending on which of the two you prefer).

It should be fixed in the next release of CIS (hopefully) :slight_smile:

Hi Beanie,

Thanks for your reply. I have not had any problems between CIS and Ad-Adware at all ??? And now that I have once again done a system restore to get rid of todays update the system (including the firewire) is running spot on again. What is the symtoms of the CIS, Ad-Aware problem?
I did try uninstalling Ad-Adware and installing the new CIS update but it still showed that the firewall is not working properly. So as I have said I did a system restore to put it back to the way t was.

Any ideas? Because I really do want the latest CIS but only if I can get the firewall working.

Many thanks


Oopsy, my mistake. The problem with Ad-Aware was with a previous version of CIS 88)

My bad.

When you reinstalled CIS, did you do a clean uninstall, or just the uninstaller that comes with CIS?

If you just used the CIS uninstaller, I recommend you uninstall using Revo Uninstaller, and then reinstall the latest (.477) version.

When using Revo, after clicking to uninstall a program, choose to run an ‘Advanced’ uninstall, which will find all the remaining CIS files and registry entries. Delete all the bold registry entries it finds, and also delete any leftover files it finds. Afterwards, reboot, and search for any other remnant files using the Windows Search function (example searches: ‘comodo’, ‘cfp’, ‘cmdagent’) and also search the registry (using Regedit) for any leftover entries (you can use the same search terms as above).

Post back here with the outcome when you’re finished :slight_smile:

Hi Beanie,

I don’t know what the heck is going on ??? Confused? me too, so let me explain.

I was all ready to do your step by step advice when I opened CIS to jot down the number of my present version which (because I did the system restore above) should have been 3.8.64739.471, when low and behold it now states that the version I have is 3.8.65951.477. But heres the problem, I am still receiving message’s which tell me that there are new updates available and that the update is 3.8.64739.477

:-[ :-[ :-[Whats going on? :-[ :-[ :-[



.477 is the latest version. This is another (88)) bug in CIS, where the updater displays an update notification, even when the user is using the latest version.

Please follow the instructions I gave, a clean reinstall might help the solve these issues :wink:

Awaiting your reply :slight_smile:

I also had problems with the update. I have run Comodo for about 6 months with no problem. First restart after I installed the latest update (by clicking on Comodo’s message that updates were available) I got message that Avira antivirus was turned off. I could not turn it back on, or run Firefox, CCleaner, Malwarebyte’s anti-malware, Gleary Utilities, Sims 2, or any other program I tried. I went back to a restore point and everything ran fine.

I tried again Mar 3, same result. The computer booted but none of the programs I tried could be opened. I went back to a restore point (this one 2 days later than the previous one), and everything worked fine again.

Am running Vista Home Premium 64.

I am unable to uninstall firewall pro. I get an error message regading loading resources cfpconfig.dll. I am trying to update, but it won’t update or let me uninstall.

Hi Beanie,

I tried doing exactly what you recomended (twice) but I am still having the same problems, eg the message states that my firewall is not working. So I have once again did a system restore because I suppose it is better having the pre updated CIS firewall running then none at all.

Is there anything else I can try? And what are the disadvantages of running the 471 and not the 477 update?

Thanks for your help


Hey Mike,

Thats odd that you’re still getting bugs after a clean reinstall :frowning:

Do you, or have you in the past, run any other security software that might conflict with the Firewall? For example, did you use ZoneAlarm before using Comodo?

If so, there might be remnants of that software still left on your computer, which might be conflicting with the CIS Firewall.

.477 was a bug-fixing release, there were no major additions. If you’re experiencing less bugs using .471, then I can’t see why you couldn’t stick with that version until Comodo fixes all the bugs in .477 :slight_smile:

By the way, are you still getting the update notification bug?

Hope this helps :slight_smile:

Hi Beanie,

No I have not used any other program such as Zone Alarm.

Except for Windows Firewall (which I have switched off) the only security software I have ever used since I purchased the laptop last year are the ones I have mentioned above.
Anyway as I have said, before I tried to update to .477 I had no conflicts whatsoever with CIS firewall, and now that I have done a system restore, everything including the firewall is running fine again. So if as you say .477 has no major additions, I will just stick with .471 until Comodo fixes the bugs.

“By the way, are you still getting the update notification bug?”

I have not had one today, so I will have to wait and see.

Once again thanks for your help Beanie.



Ok fair enough, I just thought I’d check, since it’s happened before :wink:

Yeah, you should be fine with .471 until the bugs are fixed.

No worries, happy to help :slight_smile:

Post back here/create a new thread if anything else happens.

Hi Beanie,

Me again 88) Although everything is still running fine using .471, you asked in one of your last posts if I am still getting the update notification bug, well the answer now is YES about once an hour :-TD. This started yesterday.

As it seemed so desperate, I did try updating to .477 again but I am still getting the same problems as above, so as I am sure you have already guessed, I have reverted back once again to .471

Even with the upgrade notification showing up every hour it’s no great problem, and so I was in two minds as to whether I was wasting everyones time by posting this, but just in case the guys at CIS might want to know about this small bug I thought I better post it.



Hey Mike, sorry to hear you’re still getting the bug :frowning:

Until Comodo releases a new version of CIS, the only solution I can think of is disabling automatic software updates, which should prevent the annoying update notifications.

Here’s how to do it:

Miscellaneous → Settings → Update → Uncheck ‘Automatically check for the program updates’

Hope this helps :slight_smile:

Hi Beanie,

Talk about a mega fast reply :-TU

Once again thanks for your advice



No problem mate, glad to be of help :slight_smile:


Hey Beanie

I was wondering could you offer some insights on the issue am having with Comodo.

Comodo Security Verison 3.8.65951.477 with virus data base version : 1066 “Patent Pending” ???

Veiw Errors Below.

Faulting application cmdagent.exe, version, time stamp 0x49a453b2, faulting module mach32.dll, version, time stamp 0x49a4344d, exception code 0xc0000005, fault offset 0x00009a9f, process id 0x3e0, application start time 0x01c9a3b2f73c0042.

Event ID:1000
Application Error

“Error 2”

Event 5051, McLogEvent

A thread in process C:\PROGRA~1\McAfee\VIRUSS~1\mcshield.exe took longer than 90000 ms to complete a request.
The process will be terminated. Thread id : 2736 (0xab0)
Thread address : 0x77909A94
Thread message :

Build VSCORE. / 5300.2777
Object being scanned = \Device\HarddiskVolume2\Windows\System32\DriverStore\en-US\mdmcxpv3.inf_loc
by C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe

Log Name: Application
Source: McLogEvent
Event ID: 5051
Level: Error

Logged: 3/14 - 8:19:28 PM

O0… Thanks.

I think the problem boils down to having McAfee AV active while scanning with Comodo AV.


Hey Lee :slight_smile:

Sorry I didn’t reply earlier, I was at College.

I think Frogger has the answer here, try disabling the McAfee real-time shield before scanning with Comodo :wink:

Please post back here if this helps, or if it doesn’t make a difference.

Hope this helps :slight_smile: